Selecting 'numbers' field brings up two keypads

01-04-2018 12:55 PM
New Contributor III

I'm coming across unexpected behavior when trying to fill out form fields where appearance = 'numbers'. In my form, I have 3 decimal fields. In the XLSForm for my Survey123 survey, I set the appearance value to 'numbers'.

Expected behavior:

When a user selects one of these fields to fill out, the numeric keypad will appear in the form. The user will then be able to use that keypad to input the field value.

Actual behavior:

When a user selects one these fields to fill out, the numeric keypad appears on the form. The device's keyboard also appears, covering up the numeric keypad in Survey123. User can input field values with either keypad. While the actual behavior is not preventing anyone from filling out the fields, it is a bit confusing for users.

I have tested this on both and Android and an iOS device with the same results for both. The following images depict what the screen looks like when a user selects a field where appearance='numbers' on both types of devices:

Survey123 v2.5.44 | Android v6.0.1

Unexpected behavior on Android device

Survey123 v2.5.44 | iOS v11.2.1

Unexpected behavior on iOS device

Ultimately, I just want my users to input the values using Survey123's keypad. Is there a setting I'm missing to prevent this behavior from happening? 

4 Replies
Esri Frequent Contributor

Hi Ryan,

This is a known issue with mobile devices unless you are using external keyboard. We have an open enhancement request to minimise the on-screen device keyboard when the numbers appearance has been used. I have updated the issue with your comments above.

For now all I can suggest is to remove numbers appearance and just use the on-screen keyboard.



New Contributor II

Are there any updates for this issue ?

0 Kudos
MVP Frequent Contributor

Is there a way to hide the - negative sign?  On iOS it shows a negative sign which I do not want.  Android hides the negative - which some people may actually want.

0 Kudos
Esri Frequent Contributor

Hi Doug,

Not that I am aware, I don't think there is a way to remove the negative sign.


0 Kudos