Select to view content in your preferred language

Returning The Label Instead of the Name Within Power Automate

1145
6
03-08-2021 07:37 AM
DaveK
by
Occasional Contributor

Hello! 

I'm using Power Automate to auto send emails to users with survey information once submitted. When select one fields are returned, they are returned with the Name, which are codes and not the label, which are the full name aliases. Is there any way to return the label field with the aliases instead of the name field which displays our codes? 

Thanks. 

6 Replies
DaveK
by
Occasional Contributor

@JamesTedrick, Would you happen to have any information on this? 

Thanks! 

0 Kudos
RickeyFight
MVP Regular Contributor

@DaveK Did you ever get a solution to this?

 

It was working correctly until recently. 

0 Kudos
JamesChan1
New Contributor II

Hello DaveK,

Did you ever find a solution?  I am having the same exact issue with Select One questions returning the Name instead of the Label in Outlook send email v2.  My workaround would be to change the Name to match the Label on all my items...but I rather not use that workaround.

Thank you,

CCGIS
by
New Contributor III

Hi @DaveK,

Did you ever figure this one out? I am using a select multiple but getting the text similar to Remove_this_Underscore and I would like to bring the labels instead.

0 Kudos
firstNameGreen
New Contributor

Was a solution to this ever found?

0 Kudos
RobertAnderson3
MVP Regular Contributor

I'm not sure off the top of my head if there's a way to do it within the select_one or Power Automate settings, but what I do in some cases is use jr:choice-name(choice_name, 'question') and store it in a text field that you could hide, but then pass it into Power Automate that way.

The select_multiple version is a bit different and I'm not 100% sure how you concatenate them together, but it's: jr:choice-name(selected-at(${select_multiple}, 3), '${select_multiple}')

More info: Formulas—ArcGIS Survey123 | Documentation

0 Kudos