Select to view content in your preferred language

"Survey contains errors" on web app with repeat_count repeats

987
7
03-27-2023 02:54 PM
ErikHerbergMETC
New Contributor III

I recently created a form to be used on the web app. In it, we use repeat_count to limit the form to three repeats and there are some required fields in the repeat section. When originally published on version 3.16.179, the "Survey contains errors" functionality worked really nice when Submit was pressed - if a user forgot to toggle over to the second and third repeat, the "Survey contains errors" message would appear and the form would navigate directly to the required field in the 2nd or 3rd repeat.

I republished on version 3.17.88 and that functionality has changed - now if someone forgets to toggle over to the 2nd and 3rd repeat, when they Submit, nothing happens. The "Survey contains errors" does not appear and the user is not redirected to the missing required field on the 2nd or 3rd repeat. The "Survey contains errors" only appears for questions for that specific repeat. 

Is this a bug? Or is this an intended change? Is there any way to get the behavior from 3.16 back? Attached is a very simplified version of our XLS form. Some of our users are not the most tech-savvy so I expect that some will forget about the 2nd and 3rd repeats and think the form is broken when they hit submit and nothing happens. 

Thanks!

7 Replies
ZacharySutherby
Esri Regular Contributor

Hello @ErikHerbergMETC

Thank you for reporting this! This looks to be a defect, I've gone ahead and logged an internal issue for this behavior. Please feel free to reach out to Esri Technical Support to log an official BUG. 

Thank you,
Zach
ErikHerbergMETC
New Contributor III

Thanks @ZacharySutherby . I just submitted a Bug Report. 

0 Kudos
ErikHerbergMETC
New Contributor III

I just got a response back from my Bug Report saying that the information I provided does not appear to be a report of a bug and redirected me back to posting to here in the the ESRI Community. So if anyone else on here has insight about this functionality change between 3.16 and 3.17, I would appreciate hearing about it! 

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello @ErikHerbergMETC

I've reached out to the Support Analyst directly and will get the BUG report sorted out. 

Thank you,
Zach
0 Kudos
ErikHerbergMETC
New Contributor III

Thanks @ZacharySutherby . If it helps, the number on the Bug report I tried submitting was Esri Case #03301950.

0 Kudos
ErikHerbergMETC
New Contributor III

I got a confirmation email that the bug was logged and under consideration: BUG-000157091 - Issue - "Survey contains errors" on web app with repeat_count repeats. 

Thanks again @ZacharySutherby for reaching out on my behalf. 

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi @ErikHerbergMETC ,

The fix to BUG-000157091 is available on the Survey123 website now. To make it work, just ensure your survey is published in at least the 3.18 version of Survey123 Connect or later than June 2023 on the web designer.

 

Thanks again for your feedback.

0 Kudos