"supportsApplyEditsWithGlobalsIds" issues

200
1
05-04-2021 09:28 AM
RGrant
by
New Contributor II

I am taking over a project and our client was trying to create a survey but received the error message containing "supportsApplyEditsWithGlobalIds must be true". I looked into technical articles and other questions posted and tried those solutions but it still did not work. The hosted feature layer, a file geodatabase uploaded from Pro, has editing and sync enabled and I tried to go into the overall hosted feature layer as well as the sublayers that were labeled as "false" and use the "Apply Edits" at the bottom of the REST services directory to set Use GlobalIds to True, but neither changed the JSON to say true. This is not present for all of the sublayers, but it is for all of the tables and a handful of sublayers. Could it be an issue with the GlobalIds connecting the tables and layers? 

0 Kudos
1 Reply
Philip-Wilson
Esri Notable Contributor

Hi @RGrant,

Just to confirm, have you referred to and attempted the following solutions:

https://community.esri.com/t5/arcgis-survey123-blog/how-to-enable-supportsapplyeditswithglobalids-on...

https://support.esri.com/en/technical-article/000019862

If you are still having issues I would suggest contacting Esri Support to get further advice with your current configuration of the layers.

Regards,

Phil.

0 Kudos