Publishing failed to complete: error 400

631
4
Jump to solution
06-17-2020 07:09 AM
GISManager4
New Contributor III

Publishing new survey receive error; Unable to add feature service definition. Folder is created in ArcGIS Online.

Connect Survey123 for ArcGIS v3.9.120

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello, 

Thank you for passing along the XLSForm! In taking a look at the XLSForm it looks like there are a few duplicate field names down in the groups. On lines 52-56 within the dpr_value group, the question names are the same as the questions on lines 42-46. This is the reason the publishing is failing when adding to the service definition because it can't add fields with the same name to the service. 

I had changed the questions in lines 52-56 to value3_XXXXX and the form published as expected to my ArcGIS Online Organization. 

Alternatively, if you would like to keep the same field names you can switch either the value2 or drp_value groups to a repeat so that those fields are added to a related table instead of the root feature service. 

Thank you, 

Zach 

Thank you,
Zach

View solution in original post

0 Kudos
4 Replies
IsmaelChivite
Esri Notable Contributor

Hi. To properly diagnose this issue, you will need to share your XLSForm file. You can share it in GeoNet as an attachment, or you can share it with an Esri Technical Support analyst by opening a Tech Support case.

0 Kudos
GISManager4
New Contributor III

Not an issue, please see attached XLS form.

0 Kudos
ZacharySutherby
Esri Regular Contributor

Hello, 

Thank you for passing along the XLSForm! In taking a look at the XLSForm it looks like there are a few duplicate field names down in the groups. On lines 52-56 within the dpr_value group, the question names are the same as the questions on lines 42-46. This is the reason the publishing is failing when adding to the service definition because it can't add fields with the same name to the service. 

I had changed the questions in lines 52-56 to value3_XXXXX and the form published as expected to my ArcGIS Online Organization. 

Alternatively, if you would like to keep the same field names you can switch either the value2 or drp_value groups to a repeat so that those fields are added to a related table instead of the root feature service. 

Thank you, 

Zach 

Thank you,
Zach
0 Kudos
GISManager4
New Contributor III

In previous versions, duplicates would have been flagged when saving the XLS form. I made the changes to the name field and it successfully published. Thanks.

0 Kudos