Power Automate - Accessing Creator, CreationDate, Editor and EditDate

525
3
04-21-2022 04:55 PM
CarlisleHaworth1
New Contributor III

I can't seem to access the Creator or CreationDate or Editor or EditDate attributes in the feature layer that our S123 populates. I can see them in the data so they are valid and have values, but they do not appear in the Dynamic Content list within Power Automate. Is this possible or is there a workaround?

0 Kudos
3 Replies
DominicRoberge2
Occasional Contributor III

If you feature layer is hosted on AGOL, you could create a web hook using the "tutorial" from this link:

https://www.esri.com/arcgis-blog/products/field-maps/field-mobility/use-webhooks-to-automate-workflo...

 

you will then be able to get what you are looking for

DominicRoberge2_0-1650658228925.png

 

 

Hope this help.

 

D

 

0 Kudos
CarlisleHaworth1
New Contributor III

@DominicRoberge2  We have a flow setup and running that pulls a number of other attributes, but we are unable to "see" these Creator, CreationDate, Editor, and EditDate fields. It's as if they aren't available or present from Power Automate's perspective. However, when I access the feature layer directly in AGOL or Pro, they are there so I'm wondering if it has something to do with these 4 fields being added after the data is submitted from S123? That's just speculation and I'm not entirely clear if that is the case.  

0 Kudos
DominicRoberge2
Occasional Contributor III

Sorry I was not very clear. What I was suggesting was, try to create a new Flow using the tutorial (hyperlink from previous message) to create a web hook on the hosted feature layer using Power Automate. You will then have access to all the attributes from your HFL. 

I am experiencing the same issue as you, I can't see the Creator, CreationDate, Editor, and EditDate from a flow using Survey123 task and don't see a way to change that.

Just an idea...

 

0 Kudos