Name changed of Survey123

265
3
10-06-2020 01:48 PM
AnuSawant
Occasional Contributor II

Hi,

Need help with an easy workaround to change the survey name created in Survey123 connect. When we create an initial survey we normally assign a name to it, but when we pass it to a client they want to rename the Survey name as per their requirement.

So is there any way to know an easy way to change the Survey name and where to change the name so when try to republish it then will not give any error e.g. "can't find the feature service" etc.

Thanks,

Anu

0 Kudos
3 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Anu,

To change the survey name after piublished, you can go to your AGOL organization website and under "Content," navigate to the survey folder and click the feature service item:

The click the pencil icon to rename the Feature service

0 Kudos
AnuSawant
Occasional Contributor II

Hi,

Thank you so much for the prompt response. 

I have tried doing this way but when I tried to overwrite the survey it doesn't allow me. So I have to go back and changed the name to the original survey.

The other thing I have noticed just now is if I am trying to add a new field and overwrite the survey it is taking ages to do this...... tried to close everything and republish it. Is there anything wrong with the hosted feature service health on ArcGIS online? I have created this survey using version 3.7 and now updating it using version 3.10 can it be a reason?

Thanks,

Anu

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Anu,

Did you receive any error when you try to rename the feature service name from AGOL organization? You would need to be the survey owner to rename it.

Adding a new field to the existing survey would take a while as it's updating the schema on the feature service. If your survey was creating with an older version, I would suggest to republish the survey without any addtional change first using the latest version and once the survey is updated to a newer version, try to add new field and republish. 

Did the slow publish performance occur on other surveys in the same AGOL organization using the same workflow? Network connection would be another concen here for updating feature service on AGOL. Please monitor the slow performance issue and if problem persists, you might want to contact Esri Support to log an issue to have Support Analyst help you diagnose your setup.

Thanks,

0 Kudos