Issues with geoshape map when opend with iphone browser

324
1
10-26-2020 03:07 AM
ChaimSchwartz
New Contributor II

Hi, 

I'm having issues in the following scenario:

1. Published a survey with a geoshape question, from survey123 connect.

2. Trying to open it from a browser, on an iphone.

3. The issue is that when the user taps the map question, the map question opens at a size that doesn't allow all the UX elements to show - such as the polygon icon (to digitize a shape), the search bar, and the arrow that allows the user to go back to the main form once done. 

I'm attaching an example sceenshot (you can see the polygon icon, but not the upper bars that include the search and current location buttons, and more), and you can also access the live webform here:

Social Distancing Calculator 

This is a public facing form so it would have been nice if it could be made accessible from a mobile device.

I tried a whole bunch of methods to publish the survey: designer, connect, embedded in XB or not (in my case it needs to be embedded in XB for other reasons, but I've experienced issues with both embedded or not embedded), with/withour "hide-input" appearance. Sometimes it would open OK - but never consistently. 

Is there anyway to make it work from a mobile device...?

Thanks

Chaim

0 Kudos
1 Reply
Ruth_JiatengXu
Esri Contributor

Hi Chaim,

Thanks for sharing! I tried to open a simple map question on iPhone 11 with mobile safari 13, but I was not able to reproduce the behavior. If it is possible could you please let us know the device and browser version that the issue occurred?

Thanks,

Ruth 

0 Kudos