Integromat pop-up windows are not connecting to Survey123 Questions

196
4
10-22-2021 07:39 AM
CPE_fmarshall
New Contributor

Hello!

First, I am pretty new to Survey123 and Integromat. I discovered Survey123 about a two weeks ago and started developing surveys to be used within my company. After developing a few 'test' surveys, I shared the surveys with my co-workers to get feedback on potential improvements for the surveys and/or feature reports. A co-worker asked if a feature report could automatically be generated and distributed via email once a survey was submitted. After doing some research into the question, I (fortunately) discovered this could be completed using Integromat. Additionally, I found that there were pre-built Integromat templates to accomplish this specific task! 

 

Unfortunately, this is where I ran into an issue. I am using the Integromat template called "Create a feature report and send it to email when a survey is submitted." I was able to complete the first step of the template (ie. create a connection between my Integromat account and my company's ArcOnline account. I was also able to generate a webhook for a survey on the account as shown in the picture below). 

CPE_fmarshall_1-1634910909631.png

 

During the next step (Create Report), I ran into an issue. I am able to successfully select the "Survey" and "Report Template" from the company's ArcOnline account (as shown in the picture below). 

CPE_fmarshall_2-1634911303666.png

 

However, when I select "Feature ObjectID" and "Output Report Name", I run into an issue. When I click on either field box, I get a pop-up window (as shown below). However, this pop-up window does not show any of the questions in my survey. 

CPE_fmarshall_3-1634911566821.png

 

In the tutorial video called "ArcGIS Survey123: Create Feature Reports with Integromat" (https://www.youtube.com/watch?v=Uo5N7aEvNNQ), the narrator's pop up window at the same step is connected to the survey's questions (see picture below). 

CPE_fmarshall_4-1634912151014.png

 

I was wondering if anybody else had this issue and had a solution to fix it. I checked the ArcGIS Survey123 Question board, but had no luck in finding a similar issue/solution.

 

A few details (in case it is relevant):

1) I am currently using the free edition of Integromat. According to Integromat's FAQ page, I should have access to all features/functionality in Integromat, with limitation only to the number of operations and allotted amount of transferred data. I wasn't sure if this could be a potential issue.

2) We use ArcOnline. The ArcOnline account is registered to a different email than the Integromat Account. Since I am able to connect to ArcOnline account and select surveys without any issues, I wouldn't think this would be the cause of issue.

3) The surveys were created in Survey123 Connect desktop application and then published to the ArcOnline account.

 

Thanks in advance for any assistance.

 

0 Kudos
4 Replies
ZacharySutherby
Esri Regular Contributor

Hello @CPE_fmarshall

I've seen something similar to this in the past and it was due to a configuration issue with the survey. Let's schedule a meeting to take a look into the issue and confirm if it's the same as the previous issue. If it is the configuration issue I am thinking of a few python scripts are needed to troubleshoot and resolve the issue. Please feel free to reach out to ZSutherby@esri.com and we can schedule a call to take a look and confirm if it's the same issue. 

Thank you,
Zach
0 Kudos
CPE_fmarshall
New Contributor

Thanks @ZacharySutherby  for the response. I'll send you a follow up email to schedule a meeting to discuss. 

0 Kudos
KPyne
by
New Contributor III

Was a solution ever found?

I now have a survey123 form that is not populating any custom functions/variables inside integromat

0 Kudos
CPE_fmarshall
New Contributor

Hi @KPyne ,

Sorry in delay in getting back to you. @ZacharySutherby  and I were able to find a work around solution after doing some troubleshooting. In your XLSForm for your survey, ensure that every "Label" field is filled in. The code that connects Integromat to the Survey123 form references this field. There is a coding bug that if this field is not filled in, it will not allow Integromat to connect to your Survey123 questions. Hopefully that helps you with your issue.

 

@ZacharySutherby passed the bug along to the development team after we discovered the issue. This was a few months ago and I haven't heard any updates about a patch for the bug.

0 Kudos