Integrate image/attachement in ArcGIS Survey123 report error 10.8.1

136
1
02-19-2021 08:18 AM
NicolasKleinEF
New Contributor

Hi,

We’re using ArcGIS Enterprise 10.8.1, and we’re trying to generate Survey123 reports using the web interface.

Our surveys are published using Connect, and are based on feature services published through ArcGIS Pro. Our data is stored in a sde postgreSQL database.

We have enabled the attachments on the feature class before publishing the feature service.

When we try to generate a survey123 report, the attachments are not visible in the report. We are aware that this was a limitation with ArcGIS Enterprise, according to the documentation here https://www.esri.com/arcgis-blog/products/survey123/announcements/introducing-survey123-feature-repo...

But, according to another documentation, it should now be possible with ArcGIS Enterprise 10.8.1 https://community.esri.com/t5/arcgis-survey123-blog/understanding-survey123-feature-reports/ba-p/897...

“If you are using ArcGIS Enterprise 10.8.1 or newer, as long as you do not use a feature service published from ArcMap, you can use images in your report template normally.”

The way we call the attachment to try to display it in the report is the one defined by the default report template generated automatically: ${​​attachmentquestionname | size:460:0}​​ with attachmentquestionname being the name of the question in the survey. This prints a blank in the report.

We have tried the following workaround :

${​​#$attachment}​​
${​​$file| size:460:0}​​
${​​/}​​

Which sort of worked. But, the issue is that this workaround will put all attachments together in the report. However, our users have several questions where they require attachments and they want to display those attachments in the report in a specific order.

Is the “normal” behaviour where you can call a specific attachment question in the report supported in 10.8.1 or do you have to use the workaround?

Nicolas and Alexandre

0 Kudos
1 Reply
IsmaelChivite
Esri Notable Contributor

Hi. I think the problem is that photos loaded prior to 10.8.1 do not include keyword attachments. Can you reproduce the problem using photos recently submitted?

0 Kudos