Inbox only submits when signed in as publisher of the feature service

05-13-2021 04:00 PM
New Contributor III

I am having issues with a survey that will only submit when I am signed into the S123 app as the creator of the feature service the survey is based off of. 

Basically our field interns are able to download and edit the survey from the inbox, but are unable to submit. The error is not specific, it just reiterates the instance name. However, if I sign into S123 from my admin account (that also created the initial feature service), the inbox surveys submit fine. 

I have double checked the feature service and survey to make sure the appropriate sharing is set and they have full permission to update the feature service and submit to the survey. I've tried various things and cannot get the survey to go through unless signed in as the owner of the service.

Any thoughts? I'm guessing it has to do with the way the feature service is published in some capacity? We're not in portal and it is just a standard AGOL hosted dataset. I have tried republishing a test service several times with various editor settings and it's the same error every time. I am supposed to distribute this to all of our field folks, but cannot have everyone signing in as an admin S123 obviously. I never had this problem last field season with an older version of the feature service. 

First pic is submitting under a non-feature service owner account, second is submitting successfully under the owner account. 

0 Kudos
2 Replies
by Anonymous User
Not applicable

Hi @FMBAdmin,

It sounds like there is a sharing or permission issue with the feature service or form item. When you set the sharing permissions, are you using the Survey123 website and Collaborate tab to do so, or are you changing the settings via AGO directly?

Can you please collect the diagnostic logs from the field app for one of the users that gets the error when they submit, the logs may contain some additional information to help diagnose the issue?

Also, I would suggest contacting Esri Support and opening a support ticket, as an analyst can then work with you directly on this issue to understand how the feature service and form item was published, check the settings and sharing permissions in AGO, and gather more information about the error.



0 Kudos
New Contributor III

Hi Phil, 

Thanks for the response - I actually got it figured out, but I'm curious if this is expected behavior. 

All of these surveys and services had proper permissions, however, the service was initially published as only being able to update attributes as the polygons are supposed to be read-only in the survey. I was digging through the log trying to find anything and it kept coming back to something along the lines of "geometry updates are invalid" even though no geometry edits were or should be occurring. Even if I went into AGOL settings and updated it to full blown editing capabilities (add, edit, update, delete, etc.), it's almost like the changes weren't communicated to the survey and only the admin publisher was able to submit. I republished the service with full blown editing capabilities today and then restricted everything in the form (same exact survey), and this is allowing users to submit that aren't the admin publisher. So basically changing editing capabilities on the AGOL setting side didn't communicate it and I am republishing all the services with full editing capabilities and maintaining restrictions from within the S123 form. For my own sanity as we have to do this process quite frequently, should I just plan on publishing services destined for an inbox survey with full editing capabilities and restrict it in the form only? Or is this not normal? 



0 Kudos