I am having problems with some users getting "unpacking errors" while opening a survey. What causes this?

3240
18
04-08-2018 10:20 AM
DonMaxwell
New Contributor III

I am sharing a survey with non esri users for a fiels survey. Most of them are able to load with no problems but a handful of users get "unpacking errors". Any ideas?

0 Kudos
18 Replies
JohnathanHasthorpe
Esri Regular Contributor

Hi Don

What devices are the users having issues with (model and OS) and what version of the field app are you using?

Note that this error may occur when the survey includes a large .tpk and the device enters screen lock/sleep during the download process. Is this the case your users?

Thanks

John

0 Kudos
OscarSepulveda_III
Occasional Contributor

Johnathan Hasthorpe my guys at the fire department are having the same issues.  Yet, on my iPhone 7plus iOS 11.3 it works perfectly.

This is the screenshot they sent me...  They are utilizing a iPhone X with iOS 11.3

Personnel screen shot from iPhone X

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Oscar

Are you able to share your survey xls and can you confirm whether it includes a tile package (.tpk)?

Thanks

John

0 Kudos
OscarSepulveda_III
Occasional Contributor

Johnathan for some reason when I try to reply to your comment or the main question the geonet does not offer me the option to upload my xlsx.  Any thoughts??

Also, I do not have .tpk associated with this form.

Hmm.  I just edited my message to include from "Also" and the option to "Attach" was given below. Hmmm...

Here is the link from online: https://survey123.arcgis.com/share/b5159f8107db4ad0a9d348266e123108?open=menu 

0 Kudos
OscarSepulveda_III
Occasional Contributor

Sorry.  Here is the xlsx.

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Oscar

Thanks for the .xls - I have not been able to replicate this issue with a recreated survey.

In terms of the link you provided - can you confirm that the survey is still shared, as I can't download it (it says it is unavailable). Once shared I will test on a number of devices we have here.

Also can you confirm whether this was the first time the survey was downloaded by the user or was this a repeat download?

Thanks

John

0 Kudos
OscarSepulveda_III
Occasional Contributor

Hi Johnathan,

Interesting how you do not have any problems with publishing the form publicly.  Yet, I just completely deleted the associated form and folders from our AGOL (City of Pasadena) and the Survey123 website.  And the form still has "Unpacking" issues on any mobile device....

Here are the NEW hyperlinks from the Survey123 website:

This is delay in publishing this survey is actually delaying the release of numerous other forms that we (Pasadena Fire) wanted to release to our personnel before the upcoming implementation of our ELA.

Ismael Chivite

James Tedrick

JHasthorpe-esristaff

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Oscar,

It appears you are having the same issue as https://community.esri.com/message/762064-problem-with-public-survey?et=watches.email.thread - when I attempted to open the survey with the same anonymous conditions as in that post, I am getting the same error.

0 Kudos
OscarSepulveda_III
Occasional Contributor

Hi James!

I followed the most recent entry Problem with public survey‌ from @James Mackay and yourself and still had the same result.  "Unpacking" issues were not resolved.

Any other options?

0 Kudos