Select to view content in your preferred language

HTTP 504: UNKNOWN_ERROR, when trying to edit in Suvrey123 Web

1009
8
06-13-2023 06:41 AM
Labels (1)
IhtshamAsif
New Contributor

Hello,

I'm currently facing an issue with editing one of my surveys in Survey123 Web. Whenever I attempt to make edits, I encounter an error message stating 'HTTP 504: UNKNOWN_ERROR.' It appears that only one of our licenses grants me editing privileges, while the rest are blocked from accessing this feature. Normally all the licenses can edit and there is also a edit option for all.  I'm curious to know if there are others experiencing the same problem. Any insights or shared experiences would be greatly appreciated.

Thank you!

8 Replies
IhtshamAsif
New Contributor

survey123_Error.png

0 Kudos
CristianChavarini
New Contributor III

We are having the same problem. The same happens when trying to generate reports.

Some time ago an update generated these same problems... I would like to believe that the origin is still the same...

Cannot export report (this post is about that)

0 Kudos
Bio_GIS
New Contributor III

We are also having this issue, but none of our licenses allow us to edit. 

0 Kudos
AlexUreAl
New Contributor II
I am also having the same problem, it happens to me with some surveys but not with others.

AlexUreAl_1-1686675354153.png

 

 

 

0 Kudos
BarbaraWebster1
Esri Regular Contributor

@IhtshamAsif @CristianChavarini @Bio_GIS @AlexUreAl Thank you for reporting this issue, the Survey123 team is actively looking into the cause of this issue. We will update this thread with developments, and the progress of this issue can also be tracked under support bug BUG-000159064.

0 Kudos
EricAnderson_DHS
Occasional Contributor

The workaround we've found until the Survey123 team resolves this issue is to go into the survey settings and change the version from "Always use latest (3.18)" to the version it was published under. 

BarbaraWebster1
Esri Regular Contributor

We have identified a fix for this issue and are working to get it implemented. In the meantime, workarounds include enabling version locking by selecting "Always use latest (3.18)" in the Survey123 website settings as @EricAnderson_DHS mentioned, or republishing in the Survey123 website or from Connect 3.18.123 (available at ArcGIS Survey123 Downloads).

0 Kudos
BarbaraWebster1
Esri Regular Contributor

Hi @IhtshamAsif @Bio_GIS @EricAnderson_DHS, the fix for the issue that was causing the "HTTP 504: UNKNOWN_ERROR" error has been deployed. Can you try loading the webform again and let us know if are still running into issues?

0 Kudos