Select to view content in your preferred language

How to enter multiple parameters in bind::esri:parameters column of XLS form

2001
4
Jump to solution
10-24-2022 10:51 AM
Katie_Clark
MVP Regular Contributor

Hello,

I have the text "allowUpdates=true query" in the bind::esri:parameters column for a certain question in my XLS form, as it is my understanding that this is required for a question's value to be retrieved and editable using the inbox functionality with the Survey123 field app.

I also want this question to have the parameter set to "calculationMode = always" so that the question will recalculate whenever the geopoint question is updated (it will populate with coordinate values using pulldata from the geopoint). 

I have tried separating these two parameters with commas and semicolons, but it's not behaving the way I would expect. Can someone please help with the correct syntax that is needed to have multiple parameters listed within this cell, and also if I am understanding the "allowUpdates=true query" statement correctly?

Thank you!

 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
1 Solution

Accepted Solutions
DougBrowning
MVP Esteemed Contributor

Just need a space to separate.  Give that a try

oh and its query allowUpdates=true I think 

View solution in original post

4 Replies
DougBrowning
MVP Esteemed Contributor

Just need a space to separate.  Give that a try

oh and its query allowUpdates=true I think 

Katie_Clark
MVP Regular Contributor

Hmmm, I tried using the syntax "query allowUpdates=true calculationMode=always" and it didn't return the coordinate value when I opened the survey in the inbox. (it does retrieve as expected when I only use "query allowUpdates=true".)

For additional context, these Latitude and Longitude fields are pulling values from a geopoint question with a null field type, because I have multiple geopoint questions in my survey. The behavior I'd ultimately like to see is that the fields populate with coordinates when a location is selected on the map in the survey. This point won't be recorded due to the null field type, but the coordinates will. When a user reopens this survey in the inbox if they need to edit something, the coordinates will appear from the original time they selected a location. However, if they click on the map for the null geopoint question and select a new location, I want these coordinates to be updated (hence the calculationMode set to always). I found that without this, these values weren't updating even when a new location was selected in the map.

Now that I think about this more, perhaps the calculationMode being set to always is overwriting the value being returned, since the geopoint itself isn't saved so it thinks it doesn't have any geometry input yet. 

Is there a better way to go about doing this? I was honestly surprised that the coordinates didn't update automatically when a new location was entered, since I thought "calculatioMode=auto" was the default mode for calculations in a survey?

 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
Katie_Clark
MVP Regular Contributor

@DougBrowning I marked your answer as correct because it pertained to my original question about the syntax. Thanks for the help!

What I ended up doing was just making the coordinate fields visible and instructing the field crew to make sure they hit the "refresh" icon if they update the position in the map when accessing through the inbox. Not ideal for certain reasons (can't be read-only), but it'll work for now.

Thanks again!

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
DougBrowning
MVP Esteemed Contributor

Yes it should be auto and this should work so I do not know sorry.

0 Kudos