Select to view content in your preferred language

Geopoint on Mobile in Multiple Languages Displaying Label in all Languages

667
4
04-29-2022 03:26 PM
Karl_Reinhardt
New Contributor II

I have made a survey using Connect in multiple languages and there is an issue with the Geopoint question.

When you click on the question and display the map, the top of the page changes into Arabic no matter what language you had previously been completing the survey in.

IMG_5339.PNG

When you expand the area, it becomes clear that this is happening because all of the languages labels for the question are being displayed (so it basically says "Click a location on the map to 'drop a pin'." in 9 different languages.

IMG_5340.PNG

Why are all the labels being displayed? I know the labels are in the correct column in my XLSForm because all languages are displayed properly for all the other questions.

Also, as a side note, the map is displaying the satellite view, but on desktop it shows the Topographic basemap just as I selected in Connect. I am confused why it is not showing the Topographic on mobile as well.

Any help or advice on this would be much appreciated. Thank you so much!

-Karl

0 Kudos
4 Replies
BarbaraWebster1
Esri Regular Contributor

Hi @Karl_Reinhardt,

Sorry for the late reply to this. I was able to reproduce the behavior you're seeing where the labels for all the languages are displayed for a map question when the web form is accessed from a mobile device. I filed a bug issue for this so it can be resolved. 

In my testing, the default base map that is set in Connect is the default base map when the survey is viewed on Android or iOS. If you are still seeing this behavior though please let us know so we can look into it more. 

Thanks,
-Barbara

 

0 Kudos
Karl_Reinhardt
New Contributor II

Thank you Barbara for getting back to me! Just checking this again now more than a year later.

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi @Karl_Reinhardt,

The issue has been fixed on production. You can verify the fix by adding ?version=latest to your survey URL. Please feel free to let me know if you have any question.

Thanks,

Ruth

 

0 Kudos
Karl_Reinhardt
New Contributor II

Thank you Ruth for getting back to me! Just checking this again now more than a year later.