Form built on federated existing feature service giving Invalid token 498 error

01-11-2023 08:10 AM
Occasional Contributor III

I have had on-going portal issues since about a month ago involving a cert expiring that our IT dept missed.  I'm not sure if the cert is related, as that is a possibility listed in  

I had a service become corrupted and have had multiple ESRI Support tickets trying to get things working.  This service is published through Enterprise and then added as an item in AGOL.  However, it is not letting me store credentials.  The service was a feature service that was consumed in an AGOL experience builder and had several Survey123 forms built off of it.  I had to republish the service and have been working on replacing the corrupted feature service with the new one.

All of the forms built off of the old service had the new service inserted.  They appear correctly but all are displaying the below error.  

error 498.png

I have tried looking at the submission_urls and trying to add the service to AGOL, but I'm still running into this token issue.  I need to emphasis this all worked with the previous feature service (we could not overwrite it, that would have been too easy!).


I'm struggling on what to do with this next.  Any suggestions or experience with this sort of thing?

0 Kudos
1 Reply
Esri Regular Contributor

Hello @Kara_Shindle

The steps in the KB article you linked are usually the culprit. Are you able to access the REST endpoint of the Portal feature service outside of a VPN on a mobile device or a personal computer?  

Thank you,
0 Kudos