Feature report won't print map

10-11-2022 07:49 AM
New Contributor

Hi, I'm trying to write a feature report, but it will not print the location map. Every time I try running it, I get the following error message: 

"An error occurred when rendering by the report engine. Failed to print map for ${encampment_location | mapSettings: "a1867ecc0edd4042bfeba360830bd784":100000}. Failed to print map: {"name":"request:server","message":"Error","details":{"url":"https://services7.arcgis.com/4NpNfF3A9SPUgjfC/arcgis/rest/services/service_b8e3f617c4c34042837af9be8...","requestOptions":{"query":{"f":"json","returnExtentOnly":true,"returnCountOnly":true,"objectIds":"1013","spatialRel":"esriSpatialRelIntersects"},"responseType":"json"},"ssl":false,"httpStatus":400,"messages":["This operation is not supported."],"raw":{"code":400,"message":"","details":["This operation is not supported."]}}}"

I've tried changing the sync and export options, as well as updating the map ID.

0 Kudos
3 Replies
Occasional Contributor

Could it be something as simple as the sharing settings of your web map or its contents?

If you haven't tried it already, I've found it helpful to have S123 create the sample template, and then as long as that works correctly, make incremental changes to that sample template until you find what "breaks" it. 

Sorry if you're already past that point and this is redundant.

New Contributor

I've tried going through the settings of the feature layers and web maps with no luck, but it's always possible I'm missing something. I've tried making sure that export is turned on and sync is turned off, like other workarounds suggested. The sample template is also generating the same error when I try to use it.

0 Kudos
New Contributor III

I also am getting this error when I try to print out a map. The layer was created by Survey123. It is trying to execute an end point (query) that does not exist. The layer actually has a different feature server with a query operation for the view the web map uses but for some reason it is referencing a the feature layer feature server which has no query operation.

What it references (no query - Feature Layer😞

What I wish it referenced (has query - View - is what is in the web map specified in the web map):

To enable query on the feature layer it's trying to call you have to:

Enable 'Update' or 'Delete'.

Re: Capability 'Query' is not set on the layer. - Esri Community


Once I did this I was off to the races - thanks @MJBiazar