Embed Survey123 into StoryMaps: I recently updated another Survey123 form but can no longer embed the link in storymaps. I was able to embed the survey link before but for some reason, storymaps shows this message "This website doesn't support inline embe

06-23-2020 12:58 PM
New Contributor

I haven't had issues embedding the survey until today. 

Tags (1)
0 Kudos
4 Replies
Esri Regular Contributor

Hi Ana,

Is the issue still occured with embeding Survey123 web on Storymap? Could you double check your survey to see if it's shared with everyone?

Could you also share the settings you set in the embed in website link?


0 Kudos
New Contributor III


I am also having the same issue. Here is the embedded code:

<style>.embed-container {position: relative; height: 0; padding-bottom:80%; max-width: 100%;} .embed-container iframe, .embed-container object, .embed-container iframe{position: absolute; top: 0; left: 0; width: 100%; height: 100%;} small{position: absolute; z-index: 40; bottom: 0; margin-bottom: -15px;}</style><div class="embed-container"><iframe name="survey123webform" width="500" height="400" frameborder="0" marginheight="0" marginwidth="0" title="Adopt-a-Path Application" src="//survey123.arcgis.com/share/03dc371682be43448e422ef60999e52b?portalUrl=https://maps.vbartlett.org/portal" allow="geolocation https://survey123.arcgis.com; camera https://survey123.arcgis.com"></iframe></div><script>var survey123webform = document.getElementsByName('survey123webform')[0];window.addEventListener("message",e=>{if(e.data){var t=JSON.parse(e.data);"survey123:onFormLoaded"===t.event&&t.contentHeight&&(survey123webform.parentNode.style.height=t.contentHeight+"px")&&(survey123webform.parentNode.style["padding-bottom"]="unset")}});</script>

0 Kudos
New Contributor II

I am having the same issue. I copied the iFrame embed from Survey123 and get the exact same error as above. Survey is open to everyone, it looks just like your screen grab above. I also tried an Alchemer survey iFrame embed and got the same issue saying this website doesn't support embedding.

Tags (2)
0 Kudos
New Contributor

I was having the same issue, but just got around it.

Open the survey link so you are looking at the survey in your webbrowser. Use the link copied from the open survey instead of the link provided by Survey123. 

I have no idea why... but the link from the survey itself resolved my problems.



0 Kudos