custom basemaps - tike package in survey123

534
11
03-24-2019 07:28 PM
Highlighted
New Contributor II

I have created a tile package and loaded it into the map folder on my device but Survey123 is still using the ESRI basemap and not my customer basemap

Reply
0 Kudos
11 Replies
Highlighted
Esri Frequent Contributor

Hi Jason,

Have you followed all the steps outlined here: https://doc.arcgis.com/en/survey123/desktop/create-surveys/preparebasemaps.htm

How did you create the .tpk file and how big is the file? What sort of devices are you using, please provide the make/model and OS version, and also what app version you are using?

Phil.

Reply
0 Kudos
Highlighted
New Contributor II

Hi Philip

I did but the instructions were not clear on copying the snipet of code into my existing .info – step 3

Copy the following code snippet into this file, modifying the map sources section with your own shared tile package name and URL, and click Save. This snippet should be placed within the first layer of brackets in MySurvey.info.

Regards

Jason Catlin

Reply
0 Kudos
Highlighted
Occasional Contributor II

You wont see the default ESRI maps in the Maps folder that you load your .tpk files to, something like "C:\Users\UserName\ArcGIS\My Surveys\Maps".  Once your tpk is in here it should then appear in Survey Connect Settings where you can select your default base map "Settings\Map\Default Map Type". Once you change the default map, the INFO file within your survey design folder will update accordingly and this will become your default map when the survey gets published. 

Reply
0 Kudos
Highlighted
New Contributor II

Here is a copy of the info file once it was configured in Connect for Survey123

{

"displayInfo": {

"map": {

"coordinateFormat": null,

"defaultType": {

"name": "sweepbase3"

},

"home": {

"latitude": -37.830643,

"longitude": 144.96552,

"zoomLevel": 9

},

"preview": {

"coordinateFormat": null,

"zoomLevel": null

}

},

"style": {

"backgroundColor": null,

"backgroundImage": null,

"inputBackgroundColor": null,

"inputTextColor": null,

"textColor": null,

"toolbarBackgroundColor": null,

"toolbarTextColor": null

}

},

"imagesInfo": {

"captureResolution": 640

},

"publishInfo": {

"connectVersion": "3.3.51",

"webFormTransform": true

},

"queryInfo": {

"applySpatialFilter": true,

"mode": "",

"where": ""

},

"sentInfo": {

"enabled": true

},

"serviceInfo": null

}

Regards

Jason Catlin

0407048458

Jason.catlin@broadspectrum.com

Ten Rivers

Highlighted
Esri Frequent Contributor

Hi Jason,

You do not need to follow the shared tile package steps if you are not using a shared tpk that has been shared via your AGO org as an item. If you are simply copying the tpk to the maps folder via a browser or using the new file path chooser in the app Settings -> Storage to select a different folder on a SD card for example, then all the surveys should be able to view this tpk.

If you still can not see the tpk can you provide more info about the size, type, how you created it, os/device etc?

Phil.

Reply
0 Kudos
Highlighted
New Contributor III

I have this same problem. Survey123 Connect won't recognize the new basemap tpk. I've tried every method - tpk in the maps and media folders, online, modified the .info file.

Tools:

Survey123 Connect 3.3.51
Tile Package Kreator 1.3.30
Windows 10 x64 Enterprise 1803
tpk file size 5.6 MB

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Hi Pam,

Are you able to share your xlsx file and the tpk file?

Phil.

Reply
0 Kudos
Highlighted
New Contributor II

Hi Pam,

I was using the a older version of Survey123, once I downloaded the latest version my tile package worked perfectly.

Make sure you have the latest.

regards

Jason

Highlighted
New Contributor III

Thanks Jason, I’ve been having a lot of trouble with survey123 so had already upgraded all my apps to their most current versions (survey123, connect, tile package kreator, arcgis pro). Unfortunately it didn’t fix anything.

Reply
0 Kudos