Cannot read property 'success' of undefined

1052
3
09-10-2019 07:41 AM
RalphBradt1
New Contributor II

I built a survey, published it, and installed it on my phone without problems. I collected a test point and it worked without any problems. I want others to be able to use it, but when I go to the survey and under "Collaborate" and check Everyone under "Who can submit to this survey?", I can't save it. I get "Failed to save. Cannot read property 'success' of undefined". I don't know just what this means. 

0 Kudos
3 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Ralph,

It sounds like the response from the sharing request was not quite what the Survey123 website was expecting.  Another way to check the sharing would be to go to your 'My Content' section - look for a folder named 'Survey-<Survey Name>' (where the name of your survey is instead of <Survey Name>) and check the sharing for the _fieldworker view (if present; if not, the feature layer) and the form.

0 Kudos
MJBiazar
Esri Contributor

Hi Ralph Bradt‌,

Check your survey's media folder. If you have more than 10 mb files in there, you will get an error "Failed to save. Cannot read property 'success' of undefined"when changes to the survey's sharing settings are saved. 

A defect has been logged against this behavior as is currently under consideration.

Best,

MJ

JannSamuels
New Contributor II

Hello -

I am currently getting this same error message when attempting to save a setting on the Collaborate tab - "Failed to save. Cannot read property 'success' of undefined". I have checked my media folder and I do have a 36 mb csv file there from which to pull data. While you say having more than 10 mb files in the media is the issue, you offer no fix. It's absolutely essential that I be able to change the setting I want to change. How do I remedy this situation? What is your suggestion for a fix?

Thank you,

Jann Samuels