Cannot add multiple photos in web form with constraint

1194
8
Jump to solution
04-02-2021 12:51 PM
MikeOnzay
Regular Contributor

Connect version 3.12.232

An image question in a survey with an appearance of multiline with a constraint of count-selected(${investigation_photos})<4, does not provide the ability to add more than one photo on the web form. 

mutliple images error web.JPG

Works in Connect and in the field app.

mutliple images error connect.JPG

I followed the example in this post

When I removed the constraint the web form allowed more than one photo. 

Is this a bug?

0 Kudos
1 Solution

Accepted Solutions
ZhifangWang
Esri Regular Contributor

@MikeOnzay ,

Using . (period) instead of the question name to reference the image question itself would be a workaround, such as count-selected(.)<4 .

 

Please let us know if your use case needs to reference another question other than the image question itself.

View solution in original post

8 Replies
IsmaelChivite
Esri Notable Contributor

Hi @MikeOnzay  This looks like a bug. I was able to repro.  I will add an internal note about this but I suggest you report this through Esri support so a proper incident is created.

0 Kudos
MikeOnzay
Regular Contributor

Case #02780761.

0 Kudos
IsmaelChivite
Esri Notable Contributor

Thanks. Here is the official BUG number.

BUG-000138683 - Multiline appearance is disabled in Survey123 Web Form for an Image question with a Count-Selected constraint

0 Kudos
ZhifangWang
Esri Regular Contributor

@MikeOnzay ,

Using . (period) instead of the question name to reference the image question itself would be a workaround, such as count-selected(.)<4 .

 

Please let us know if your use case needs to reference another question other than the image question itself.

MikeOnzay
Regular Contributor

This workaround resolves my use case. Thanks.

linaabadia
New Contributor

Hola me podrian ayudar estoy tratando de crear un reporte en survey, que lleva 1 mapa y una firma como adjunto. cuando creo el reporte me sale este error.

linaabadia_0-1619716794151.png

 

Error: An error occurred when checking the report template. Failed to parse ${API_13212_FRM_FEC_Encuesta_C1_point | size:400:300} since field name or parameter API_13212_FRM_FEC_Encuesta_C1_point cannot be found in the current parsing scope.

adjunto la plantilla por si alguien me puede ayudar. gracias

0 Kudos
ZhifangWang
Esri Regular Contributor

@MikeOnzay ,

This issue (BUG-000138683) has been fixed in the September 2021 release of Survey123 (version 3.13). To utilize the fix, you need to republish the survey in Survey123 Connect 3.13 or turn off the version lock of the web app.

 

Thanks again for your feedback.

0 Kudos
MelissaJ_TX
New Contributor II

Hi @ZhifangWang and @IsmaelChivite!

I'm seeing this issue again now in the web app, where the Count-Selected constraint on a multiline image does not allow for multiple attachments. I'm using the most current version of S123 Connect, have republished the survey since the 3.13 update, and do not have the survey's web app version locked. I've tested with and without the required setting and in multiple browsers.

With Constraint:

MelissaJ_TX_0-1644599907141.png

Without Constraint:

MelissaJ_TX_1-1644599994108.png

The workaround outlined above still works, but wanted to point this out nonetheless. Let me know if I need to submit a new bug or if the old one can be reopened. (Unrelated....emojis don't always work well in replies in GeoNet :smiling_face_with_smiling_eyes:🤷‍)

Thanks! Melissa

0 Kudos