Basemap will not change to custom web map in survey123

532
2
04-17-2020 05:40 AM
JessicaJThompson
Occasional Contributor

Hello!

I have followed the steps to change my basemap in Survey123 Connect to my personal web map. When I preview it in survey123 the map is there. However, when I preview the survey in a web browser the map seen is the World Topo Map. I can click on the basemap icon and select my map in the survey, but I want it to be the default. I have also tried changing it to the Open Streets Map and that didn't work as well. 

This is the doc I used to guide me through the change. 

Include a map in your survey—Survey123 for ArcGIS | Documentation 

According to this the change should be automatic and I do not have to republish my survey. I have not tried to manually add it through code (a little uneasy about doing that at this point, but will try if I must).

Any suggestions? I attempted yesterday. Saved and closed everything. Tried again this morning with no difference. 

This is a link to my survey:

https://survey123.arcgis.com/share/b8b74599ca0e48228323a2a455942aac?portalUrl=http://SAVGA.maps.arcg... 

Thank you!

0 Kudos
2 Replies
CMV_Erik
New Contributor III

This sounds like the bug that led me to immediately downgrade to Connect 3.5 after upgrading to 3.7 a few months back. Any change I made to the default basemap in 3.7 was ignored, whereas 3.5 worked as normal. I found other people reporting similar issues with post-3.5 versions - here's one example: Web showing different basemap 

Coincidentally, I was hoping for a fix for this issue this morning. Assuming this sounds like the same issue, may I ask which Connect version you're using? The link above says it was planned to be fixed in an early 2020 release, and I think 3.9 was just released. 

JessicaJThompson
Occasional Contributor

Thank you! I am going to try the upgrade to 3.9

I am currently using Survey123 Connect for ArcGIS 3.7.62.

Hopefully this change will also help my time formatting issue as well!