All other users, except me, stuck on "Getting Service Information" when submitting surveys. I made the survey and it's open to public

992
3
Jump to solution
04-28-2023 01:33 PM
clarklog
New Contributor II

I can submit surveys. But no one else can unless they log into my account on their device.

0 Kudos
2 Solutions

Accepted Solutions
MobiusSnake
MVP

Besides the form, have you ensured the feature service it writes to is also public?

View solution in original post

ChristopherCounsell
MVP Regular Contributor

Most likely answer is this. Also consider:

  • Have you renamed the feature service?
  • Have you changed it from its folder location? 
  • Have you changed the feature service owner?
  • Is the view layer shared (for surveys build with web form designer)?

It should not be renamed or moved outside of the folder it was created in. Often the owner won't have issues, but other users will.

If access is shared via a group, and the form + service are shared to the group, confirm that the users have accepted the invite to the group?

Any of these don't work - we'll need more information on how you created the survey and what changes were made after this, if any.

View solution in original post

3 Replies
MobiusSnake
MVP

Besides the form, have you ensured the feature service it writes to is also public?

ChristopherCounsell
MVP Regular Contributor

Most likely answer is this. Also consider:

  • Have you renamed the feature service?
  • Have you changed it from its folder location? 
  • Have you changed the feature service owner?
  • Is the view layer shared (for surveys build with web form designer)?

It should not be renamed or moved outside of the folder it was created in. Often the owner won't have issues, but other users will.

If access is shared via a group, and the form + service are shared to the group, confirm that the users have accepted the invite to the group?

Any of these don't work - we'll need more information on how you created the survey and what changes were made after this, if any.

clarklog
New Contributor II

It wasn't. That must be it. Thanks!

0 Kudos