Google Analytics not fully working after April 2023 update?

877
14
Jump to solution
04-29-2023 08:24 AM
PeterKnoop
MVP Regular Contributor

Google Analytics for ArcGIS StoryMaps hosted in our ArcGIS Online organization stopped correctly recording data on 27 April. This time frame coincides with the recent updates to StoryMaps to enable Adobe Analytics.

The issue we are seeing is that no views are being recorded, however, users and events are still being tracked. We are using Google Analytics 4 (GA4.)

Anyone else experiencing this issue?

0 Kudos
1 Solution

Accepted Solutions
OwenGeo
Esri Notable Contributor

Fixes for the two analytics issues have been deployed. Please let us know if you are still experiencing either one of these.

Owen Evans
Lead Product Engineer | StoryMaps

View solution in original post

0 Kudos
14 Replies
PeterKnoop
MVP Regular Contributor

As a follow-up, trying to disable Google Analytics on the problematic ArcGIS StoryMaps is also failing. If I go to Story settings, toggle Enable analytics to off, then publish the StoryMap, when I revisit Story settings, Enable analytics is back to being toggled on. These are StoryMaps that were originally created awhile ago.

0 Kudos
OwenGeo
Esri Notable Contributor

@PeterKnoop -- Actually, we are not yet able to reproduce the issue you mentioned with analytics being re-enabled after turning them off and republishing. Can you confirm that you're clicking SAVE in the Story settings after toggling analytics off, and that if you go back in to the settings before publishing you also see analytics toggled off?

I

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
oevans_storymaps
New Contributor

@PeterKnoop -- Thanks for reporting this. We saw a similar issue in our testing and fixed it before the release. I wonder if this is the same one that somehow came back or a different issue...

Are you able to share the links to these stores so we can take a look? (I assume they are publicly shared, yes?)

0 Kudos
PeterKnoop
MVP Regular Contributor
0 Kudos
OwenGeo
Esri Notable Contributor

@PeterKnoop -- Thanks again for reporting these issues, and I apologize for the impact this is having.

We've identified the issues and are working on a fix. It looks like the page views are still getting captured, but not in the exact same way. As a workaround, you can find them under Event count > user_engagement.

MicrosoftTeams-image (14).pngMicrosoftTeams-image (15).png

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
OwenGeo
Esri Notable Contributor

We are in final testing and plan to deploy the fix for both of these issue tomorrow evening, 5/4.

Owen Evans
Lead Product Engineer | StoryMaps
OwenGeo
Esri Notable Contributor

Fixes for the two analytics issues have been deployed. Please let us know if you are still experiencing either one of these.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos
PeterKnoop
MVP Regular Contributor

@OwenGeo I'm out in the field, but a brief look suggests the issue is resolved. Thanks for the quick fix!

AbiDhakal
Occasional Contributor III

@OwenGeo 

I'm not being able to track ArcGIS StoryMaps story created in ArcGIS Enterprise Portal.

When I test the TrackingID in Google Analytics page, I encounter an error. The error message is: "Your Google tag was not detected on your website." Additionally, I cannot not see the 'collect' request in the web browser developer tools.

However, ArcGIS StoryMaps story created in ArcGIS Online has no problems being tracked.

Is there something more that needs to be done, other than just insert the TrackingID, to track a StoryMap created in Portal?

Thank you,
Abi

0 Kudos