ArcGIS RuntimeQt and Qt6?

393
4
Jump to solution
11-25-2020 01:33 AM
NorbertThoden
Occasional Contributor III

Hi!
I ask myself about the Qt6 support. When will ArcGISRuntimeQt will support Qt6 and when will qt6 be required?

Can you share your roadmap or expectations about this issue?

 

Thanks in advance

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
LucasDanzinger
Esri Frequent Contributor

Hi Norbert -

 

Due to many very large architectural changes in Qt 6, we won't have a release of Runtime SDK that will work with Qt 6 when it is first released. Changes to the rendering stack will be the biggest change, but there are also changes to the asynchronous workflows and QML environment that will take some time to adapt to. As such, the Runtime SDK will be based on 5.15.x for at least the next several releases. We are still in the early stages of planning out all of the impacts and changes related to a Qt 6 upgrade (some of the pattern changes will likely require breaking API changes). At the moment, we are not sure of a timeline for which we will have a Qt 6-based SDK available. 

 

Can you share with me your plans, requirements, and timeline so we can take this into account?

 

Thanks,

Lucas

View solution in original post

4 Replies
LucasDanzinger
Esri Frequent Contributor

Hi Norbert -

 

Due to many very large architectural changes in Qt 6, we won't have a release of Runtime SDK that will work with Qt 6 when it is first released. Changes to the rendering stack will be the biggest change, but there are also changes to the asynchronous workflows and QML environment that will take some time to adapt to. As such, the Runtime SDK will be based on 5.15.x for at least the next several releases. We are still in the early stages of planning out all of the impacts and changes related to a Qt 6 upgrade (some of the pattern changes will likely require breaking API changes). At the moment, we are not sure of a timeline for which we will have a Qt 6-based SDK available. 

 

Can you share with me your plans, requirements, and timeline so we can take this into account?

 

Thanks,

Lucas

View solution in original post

NorbertThoden
Occasional Contributor III

Hi Lucas!

Thank your for your clear statement.

We just started to take Qt6 into account. . If we have relevant news i will let you. But i assume that i will take time on our side too.

 

Stay healthy

Norbert

0 Kudos
KennSebesta
New Contributor III

It's been a few months so I figured I'd ping you guys and see whether there is a roadmap for Qt6 support. Qt6.2 is in beta release right now, and will almost certainly reach final release within two or three months. Qt6.2 is the moment Qt6 achieves feature parity with Qt5 and moreover it's an LTS version, so for those of us looking at switching over this is the time to start moving in that direction.

After our experience upgrading from Qt4 to Qt5, the upshot is that we want to start this process as early as possible, in part because it means less future code to upgrade and in part because Qt4-->Qt5 had tangible benefits and we anticipate Qt5-->Qt6 will be the same. 

There's no burning fire, but it's probably not practical to stick with Qt5 for years to come. If ArcGIS SDK's roadmap doesn't have Qt6 support in the foreseeable future it would be good to know this in order to plan accordingly.

0 Kudos
LucasDanzinger
Esri Frequent Contributor

We are working on developing a road map right now. Our API depends on certain modules (positioning, sensors, multimedia, etc) that weren't available until 6.2, so this is the first viable release we have to build and test our API with Qt 6. Along with building our API against Qt 6, we are interested in taking advantage of new Qt 6 paradigms that might make for a better product, like new async patterns, C++ property binding, removing QML versioning, and more. So with all of that said, Qt 6 support is in the foreseeable future, but I don't have a timeline for you right now.