.NET Runtime .geodatabase file not downloading correctly

11-06-2016 02:37 PM
New Contributor

Running into the following issue: I had a functioning setup where a sync-enabled feature service on ArcGIS Online was connected to and then a local copy downloaded to a .geodatabase file for offline use. All was well for the past several months and then I noticed recently that when I ran the function, it would seem to work but the .geodatabase file is only 2KB (definitely not containing the features). Then when the code attempts to add the features to the map, I receive the following message (seems to be a SQL default): "File opened that is not a database file : " 

As far as I can tell, all credentials are being handled appropriately because I can access the layers in an online mode directly from the application.

I have re-uploaded feature data to AGOL, used different feature layers for the download, even went so far as to build a new test app using the tutorial here: Create an offline app—ArcGIS Runtime SDK for .NET | ArcGIS for Developers 

And even with the tutorial as written, the same result occurs. An unusable tiny .geodatabase file.

Anyone have any thoughts on what I'm running up against here? Thanks...

0 Kudos
0 Replies