quick capture tracking stop in background

275
11
02-09-2021 02:28 AM
AdrianPatrulescu
New Contributor II

Hi,

I have encounter a problem with quickcapture app

When I start recording track (pressing an app button) the track start recording.

After a short time i close the screen to save battery. I realized that after a while the application no longer records the track and start recording only when screen is on again. The result is track with strait lines between points

I want to mentioned that the stay awake setting is on (in the app settings)

Can anyone help me?

Thank you!

11 Replies
DanPatterson
MVP Notable Contributor

I moved your post to the Quickcapture community to give you a chance of getting an answer.

The Community Basics link at the top of the page might be a good read should you want to find out how to navigate the Community spaces.


... sort of retired...
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Please can you confirm your device and operating system version. Thanks

0 Kudos
AdrianPatrulescu
New Contributor II

the device is Fairphone 3

Android version: 10

Thanks

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Adrian - can you check the location permissions for the QuickCapture application on your phone. In order for QuickCapture to capture data in background, the app needs to have allow all the time access. Also, make sure you are using the latest QuickCapture version from the store (currently 1.8).

 

0 Kudos
BethLawson
New Contributor II

Hi, I am having the same problem and switching the app permissions to "allow all the time" has not corrected the issue. This seems to have only started happening recently, and I have had a number of people who use our quickcapture apps mention this problem. Attached is a screenshot of the straight lines resulting from the location only being captured when the phone screen is on (lines should have followed the road). I am running the app on a Galaxy S9 on Android 10, and have always had the stay awake setting switched on.

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Adrian and Beth

We have a fix for background location in Android 11, due for release in a couple of weeks. Can you try out the early adopter build 1.9.120 here: https://earlyadopter.esri.com/project/version/admin/default.html?cap=9c6a1e4687c34c7fb5c6f8f4e0bc2df... and confirm if this is working for you.

Note that the alllow all the time permission is not needed for this version. 

Please let me know how you get on.

 

Thanks

John

0 Kudos
BethLawson
New Contributor II

Hi Johnathan,

I am getting a "app not installed" error when I try to install the 1.9.120 build - I am assuming this is because I am only running android 10. Will the background tracking ever be fixed on android 10 devices or will the fix only be for 11 onwards?

Thanks,

Beth

0 Kudos
JohnathanHasthorpe
Esri Regular Contributor

Hi Beth 

Before installing 1.9.120. Make sure that you uninstall any existing versions of the app that are already on the device. 1.9.120 should install on android 10 without any issue.

Please let me know if you are still having issues. You can contact me through quickcapture@esri.com too.

Thanks

John

0 Kudos
BethLawson
New Contributor II

Hi John,

Thanks for that! The background tracking works really well 🙂

Have discovered another small problem with this version though - I will email you.

Thanks,

Beth

0 Kudos