Invalid Text error

451
3
Jump to solution
04-19-2021 05:57 AM
DEI
by
New Contributor III

Hello,

A field worker using an iphone 8 is getting an 'Invalid Text' error when trying to identify a location via a Button user input. No issues for others using android devices. Is there a solution for this for those using ios?

0 Kudos
1 Solution

Accepted Solutions
XiaoxuLi
Esri Contributor

Hi DEI,

Does the button user input has an input mask applied? It'd be helpful if you can share the user input configurations so we can try to replicate the problem. For now, you can try: (1) Update the QuickCapture app to the latest 1.9.127 version and see if the issue still exists. (2) Double-check the input mask (if it has) and add Hint text to demonstrate what is the expected input format. (3) Set the button user input as non-required, so user can Skip the dialog.

Thanks,

Mandy 

View solution in original post

3 Replies
XiaoxuLi
Esri Contributor

Hi DEI,

Does the button user input has an input mask applied? It'd be helpful if you can share the user input configurations so we can try to replicate the problem. For now, you can try: (1) Update the QuickCapture app to the latest 1.9.127 version and see if the issue still exists. (2) Double-check the input mask (if it has) and add Hint text to demonstrate what is the expected input format. (3) Set the button user input as non-required, so user can Skip the dialog.

Thanks,

Mandy 

View solution in original post

DEI
by
New Contributor III
Thanks Mandy & John,

There was an input mask prefix that included the \ character before and
after each letter “\S\T\M\”. I removed the \ characters to just “STM” and
the guys tried it this morning and it seems to be working now.
0 Kudos
JohnathanHasthorpe
Esri Regular Contributor
Additionally, could you share your project with us?
If you create a group and invite the user: qccreator to it. Share the project and layers with this same group.

We'll take a look. Thanks

John
0 Kudos