ArcGIS QuickCapure- Latest Update Broke User Input Parameter Functionality

203
1
Jump to solution
08-23-2021 11:27 AM
Labels (1)
Amanda__Huber
Regular Contributor

Hello QuickCapture Team,

We have a project that's about to go live and it appears that the latest update to ArcGIS QuickCapture may have broken a functionality we're depending on. 

We're leveraging url parameters to open the mobile app, when opening the app the parameters are not bein passed and instead another "capture field" is writing to both it's designated field and the user input field. 

We saw the syntax for user input parameters has changed (since the latest update for the addition of multiple user inputs) (see below). We updated the syntax of our url and the behavior above is still persisting.

Amanda__Huber_0-1629743079507.png

Amanda__Huber_1-1629743136436.png

Documentation of the change: 

https://doc.arcgis.com/en/quickcapture/help/integratewithotherapps.htm 

userInput

Specifies the value with which to populate the project user input variable.

userInput:001=Area7

 

This appears to be a bug (app in on latest version as well). 

 

Thanks so much, 

Amanda

 

 

0 Kudos
1 Solution

Accepted Solutions
JohnathanHasthorpe
Esri Regular Contributor

Hi @Amanda__Huber Thank you for your feedback! We published a blog to explain the use of 'Project user input URL parameters' a bit further with more details, please see https://community.esri.com/t5/arcgis-quickcapture-blog/using-urls-to-populate-project-user-inputs/ba...

View solution in original post

0 Kudos
1 Reply
JohnathanHasthorpe
Esri Regular Contributor

Hi @Amanda__Huber Thank you for your feedback! We published a blog to explain the use of 'Project user input URL parameters' a bit further with more details, please see https://community.esri.com/t5/arcgis-quickcapture-blog/using-urls-to-populate-project-user-inputs/ba...

View solution in original post

0 Kudos