Select to view content in your preferred language

Basic Map Tool dev sample fails in ArcGIS Pro 2.1.2

05-01-2018 03:14 PM
Regular Contributor

Since updating to ArcGIS Pro 2.1.2 a custom Add-in built based on the Basic Map tool example from GitHub is failing. It returns "Exception while waiting for a Task to complete. Caller: ClearFinishedTasksImpl, File: C:\ArcGIS\ArcGISDesktop\ArcGISEditing\ArcGIS.Desktop.Editing\EditLib\Awaitable.cs, Line: 339. See the inner exception for additional information."

Any ideas or pointers on changes in the 2.1.2 SDK implementation that could have brought this about?

0 Kudos
1 Reply
by Esri Regular Contributor
Esri Regular Contributor

Hi Richard,

 I have 2.1.2 of Pro installed and tried the 'Basic Map tool example from GitHub' and it worked fine without any problems.  I assume at this point that your add-in problems are caused by some workflow related issues in your custom add-in code.  Without a code sample of the offending snippet we can't get to the source of the problem.  Maybe you can comment out portions of your code until you see the add-in work again.  This should give you an idea as to the offending code snippet.

0 Kudos