Why do I get inconsistent results in ArcGIS Pro?

07-02-2021 11:55 AM
New Contributor


I'm going nuts with an issue I've seen a number of times in my work with ArcGIS Pro.  In my latest issue, I ran the process of displaying the XY Data from an Excel file to display points on a map.  During this process ArcGIS Pro arbitrarily dropped approximately 3,000 rows of data from a table with 35K rows.  (I combed through the dropped data and couldn't find a rhyme or reason for why it dropped the rows.)  Next, I ran the data through a Model Builder flow (not realizing that the table was 3K rows short).  All of the spatial joins and exports worked fine.

Once I realized that the 3K rows had been dropped in the Display XY Data process, I ran it again with the same table and this time all 35k rows came through just fine.  However, when I ran the resulting table through the same Model Builder flow one of the spatial joins only assigned data to 1/3 of the rows.

Why is ArcGIS Pro dropping data and giving me inconsistent result when I run the exact same processes with the exact same data?

I am using ArcGIS Pro 2.8.1 on an i7 machine with 16GB of RAM running Windows 10.  The spatial join was on a congressional district layer.

0 Kudos
1 Reply
MVP Esteemed Contributor

Have you tried Excel To Table (Conversion)—ArcGIS Pro | Documentation

to make a gdb table first?

If the issues persist or new ones arise, then Tech Support would want to see what the issue is, so I would definitely contact them.

... sort of retired...
0 Kudos