Why are my confusion matrix values all zeros? (ArcGIS Pro 2.4)

11-05-2019 03:00 PM
New Contributor II
I have a raster dataset (of a field of crops) with 5 bands that I have classified using Image Segmentation. I'm trying to get the kappa value to investigate the errors of my classification method, but the matrix turns up empty.

I started with a raster dataset that I segmented, and from that segmented image, I generated training samples. I then classified the segmented image (using Random Tree) into 5 classes (leaves, grain heads, soil, shadows, and ground targets). The outputs generated from that process included a classified raster and a ECD file.

From there, I used the "Create Accuracy Points" to create the points needed to compute the confusion matrix. Parameters used:

  • Input Raster = {The raster I just classified}
  • Target Field = "Classified"
  • Number of Random Points = 500
  • Sampling strategy = "Stratified Random."

I then tried to compute the confusion matrix, but all my results are zeros. I'm not sure why. Is there something that I have to do to merge my accuracy points with the classes of my classified raster

0 Kudos
1 Reply
New Contributor

Hello, I know this is a long shot since this post is almost 3 years old, but do you remember if you ever solved this issue? I'm currently experiencing the same problem.

Thanks in advance!

0 Kudos