What happened to filter on keystroke in Pro Select by Attributes?

71
4
Jump to solution
07-22-2019 08:32 AM
Highlighted
MVP Frequent Contributor

I may be late to this, and there is already a post (that I can't find) and a bug #, or, more likely, I'm doing this wrong. In Pro select by attributes, when typing the first few letters of a value in a string field (no domain), it does not filter to that value. E.g in photo, when I type "Cade", I expect to see all the strings that start with "Cade". 

In Arc....

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

In ArcGIS Pro, the queries are case sensitive.  Try using Cade vs. cade instead in AGP.  Does it go to the first in the list that meets the Cade criteria?

View solution in original post

Reply
0 Kudos
4 Replies
Highlighted
Esri Frequent Contributor

In ArcGIS Pro, the queries are case sensitive.  Try using Cade vs. cade instead in AGP.  Does it go to the first in the list that meets the Cade criteria?

View solution in original post

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

Correct! But there is a problem......

If I type "Ca" and mouse focus brings me to "Cable Cemetery Road", fine. But if I select "includes the value", type Ca, mouse focus scrolls me to "Cable Cemetery Road", which gets checked (?!), when that was not my intent to populate the expression with "Cable Cemetery Road", I just wanted to get to the list of strings that start with "Ca". 

Highlighted
Esri Frequent Contributor

Thomas - I tested your workflow mentioned and have the same result using AGP 2.4.  If I had to guess (not being an Esri Developer), this is expected behavior for "includes the value(s)"  If I used the "contains" operator, typing in "Br" for "Braun" street does not go down in the list to records with Braun...hmm...should be consistent IMHO.  Kory Kramer‌ - have you seen this before?

Reply
0 Kudos
Highlighted
Esri Notable Contributor

Looks like this  

Reply
0 Kudos