Unable to publish a layer referenced to registered data from ArcGIS Pro to Portal

236
4
05-31-2022 04:31 PM
Hayley
by
Occasional Contributor II

Hi there, 

We have a registered layer which we would like to publish to our Portal. One of my colleagues is able to see the "reference registered data" (circled in pink) option but I am not. We are working on the same geodatabase, server and using the same referenced layer. 

Is there a reason why I can't see it but others can? Does this require a special publishing privilege?

Hayley_0-1654039557720.pngHayley_1-1654039589600.png

Thanks!

 

HL
4 Replies
magisian
Regular Contributor

Yes, this is a privilege that can be revoked/assigned with custom user roles.

https://pro.arcgis.com/en/pro-app/2.8/help/sharing/overview/web-feature-layer.htm

https://enterprise.arcgis.com/en/portal/latest/administer/linux/roles.htm#ESRI_SECTION1_911D5C251A30...

Please talk to your Portal for ArcGIS administrator to find out what role (and privileges) are assigned to you. 
It's likely that they want to restrict this to users who have gone through training or understand how to work with server-based publishing, user-managed data, etc.

Cheers

Please don't forget to share kudos and accept solutions 🙂

0 Kudos
Hayley
by
Occasional Contributor II

The issue is that I am using the Portal admin account and unable to see it. But my colleague who logs in with the same admin account can see it. 

That is where the confusion is, we are both using the admin account with the exact same privileges but only one of us can see the option. 

Thanks for your response 🙂

HL
0 Kudos
magisian
Regular Contributor

Hi Hayley,

If you are using the same portal admin account you can likely rule out a lot of issues tied to privileges or ownership.

Likewise, if the data was not registered with server you would get the option and then receive a warning that the data would be copied to the server (as a file geodatabase).

Using the same machine also rules out issues like different versions of Pro.

Are you able to expand upon what the data is? Can you confirm it is the same map and layer as the other user? If it is a database connection, how is it authenticated? Can you share a screenshot of the map content pane? 

Any other differences you can identify between you and the other user who can publish ok?

Would probably recommend reaching out to Esri technical support who may be able to actively look into it. Most issues with publishing are tied to errors or warnings; not absence of options.

What do you have set as your active portal? Is it the Portal for ArcGIS or ArcGIS Online? You may need to switch active portals, even if you are signed into Portal for ArcGIS.

Cheers,

0 Kudos
magisian
Regular Contributor

I would check your active portal first - it's the only thing I can think of that would remove the option.

0 Kudos