Staging failed when trying to publish hosted feature layer in Pro

4870
11
02-26-2018 02:53 PM
AdrianWelsh
MVP Notable Contributor

I have about four layers I am trying to publish from ArcGIS Pro‌ to ArcGIS Online‌ and I keep receiving a "Staging failed" error with no other details:

I found this article:

Error: Staging failed 

I tried to run through the troubleshooting but none of these options worked.

Facts: I can publish regular data from a regular coordinate system.

I am using a custom coordinate system and converted CAD data into a file geodatabase.

I have never had an issue with publishing converted CAD data from a custom coordinate system.

I tried one layer at a time and it still would not publish.

Are there any other ideas on what I can try to publish this data to the web?

I've even tried overwriting an existing hosted feature layer and creating a new feature layer. I do not have time-enabled data (as far as I know). There is no custom symbology.

Thanks.

11 Replies
AdrianWelsh
MVP Notable Contributor

Path name length. That was the issue. It would be nice if the error could indicate this instead of spending an entire day fretting!   

I am not sure what the character limit is on the path name, though. My file geodatabase was 205 characters. Here is another erroneous warning that you can get with this issue:

001707: Data cannot be opened: .—Help | ArcGIS Desktop 

But, it still does not say what the path limit is (it may depend on the operating system - I am using Windows 10 64-bit).

Either way, if you come across the "Staging failed" error when publishing data (I'm currently using ArcGIS Pro 2.1.1) and not sure what the issue is, check to make sure your file path is under 200 characters or so (maybe under 150? who knows!).

AdrianWelsh
MVP Notable Contributor

It looks like this is now a bug:

BUG-000112137: Staging failed error in ArcGIS Pro when sharing a web layer that is able to be published from ArcMap

I don't know where the "able to be published from ArcMap" segment came from, but I guess that's not the point.

0 Kudos
deleted-user-Kq6tBi-9bAzM
New Contributor II

I had the same issue but with a different solution. I was trying to overwrite a web layer with an updated version. The file path (82 characters) wasn't the issue. Turns out my layer editing had rendered the symbology incorrect. I re-did the symbology (as mentioned in a different context right at the bottom here: Error: Staging failed) and it published fine. 

JordanCarmona1
New Contributor III

I ran into this issue as well. My logs read Error99999999999

After some head-scratching, I pin-pointed that this issue must be because of a new domain that I added into the schema.

We are using Arc Collector to do our Traffic Asset Management; as part of this, we are attributing the street that the sign is on, and the cross streets that are immediately previous and ahead. Instead of writing out these street names, our field staff asked for a pick-list/drop-down menu. 

So I created a domain with all of our unique streets (approximately 3.4k entries). As soon as I added this to the schema the layer refused to stage. As soon as I removed it, it published just fine. 

So now I have questions:

   1. What is the domain limit when publishing from ArcPro to AGOL?

   2. What is the domain limit in AGOL of uploading an item directly?

arccollector‌ domain codes‌ add domain‌ streets locator‌ #arcgisonline question#esri staff

To solve the actual field collection issue, I could add in three new fields and make this a segmented alphabet subtype, but the issue is that the field staff wants less fields, not more.

I could use a spatial trigger to grab the closest streets, but the accuracy of this breaks down at any cross-street/intersection. We'd also need to implement a street network to grab the two closest cross streets. 

I'd appreciate any advice on this!

AdrianWelsh
MVP Notable Contributor

Jordan,

Great questions. I wish someone from the ArcGIS Online could chime in on this!

If you're going to the Esri User Conference‌, you could easily nail someone down there and ask them face-to-face.

0 Kudos
ModernElectric
Occasional Contributor III

Has there been any new information about this problem? I have one File GDB (Electric System) composed of all kinds of points and lines with a number of domains and .PDF attachments. This one has no problem updating into ArcGIS Online. However, I have another File GDB (Water System) also composed of points and lines, domains, attachments. I have one specific feature class that is triggering the failure. Its a point feature class with domains and attachments just like everything else. But, this is the suspect that will not allow the process to finish. Is there something else that will prevent a feature class inside ArcGIS Pro from updating to a feature layer to ArcGIS Online? I cannot figure out why this specific point feature class is making the update process crash. I am working on a project on converting the data from ArcMAP to ArcGIS Pro (Long Story). 

AdrianWelsh
MVP Notable Contributor

Out of curiosity, do you have long path names?

0 Kudos
ModernElectric
Occasional Contributor III

I have a few different GDBs that I am using to update ArcGIS Online. One of them is giving me zero problems when doing the staging process. The path name is really not that long. One thing I have noticed in the GDB that I am having issues with is the Point Feature Class(s) is causing the crash, but not the Line Feature Class(s). I know its not the length of path because the Line Feature Class(s) update just fine but when I include the Point Feature Class(s) - that also have attachments associated to the features, I get the Staging Failure.

0 Kudos
AaronKoelker
Occasional Contributor III

I ran into this error today as well with a similar scenario. Narrowed the issue down to a single point feature class that was keeping the group from uploading to AGO -- and realized that while I had an attachment table and relation in my fgdb for that feature class, they weren't correctly associated with it (I think I did some renaming at some point). So after deleting those attachment items and re-enabling attachments on the feature class, I was able to publish all the layers just fine.

Seems like a number of things will trip the staging error, but worth checking your attachment settings.

-Aaron