Split a polygon

196
2
06-10-2021 11:16 AM
Labels (1)
MarcelSt-Germain
Regular Contributor

What I'm missing there in Pro.  Always do that in arcmap but, in Pro I have a problem.

Like you can see, I have a polygon selected to cut named "Système de canal de NY".

Before with selectionBefore with selection

I do my cut just just over the red polygon an, like you see I have now two polygon "Système de canal de NY".

Unfortunately, the selected polygons have disappear in the process.  So I can't know which one to delete since even the flash doesn't work to highlight each of these. Never happen in arcmap.  

 

After the splitAfter the split

0 Kudos
2 Replies
Scott_Harris
Esri Regular Contributor

Hi @MarcelSt-Germain 

Perhaps you are symbolizing by a field that has a domain assigned? See the notification that pops up regarding domains in the Split tool (in your screenshot).

The Split tool in ArcGIS Pro will respect the split policy that is defined on the source geodatabase. This is mentioned in the documentation for the Split tool: Split a feature—ArcGIS Pro | ArcGIS Desktop

You can check the split policy by right-clicking on the layer in the Contents pane > Design > Domains. The Split Policy will be listed here. It sounds like your data could be set "Default", but perhaps you want to set it to "Duplicate".

Thanks,

Scott

0 Kudos
MarcelSt-Germain
Regular Contributor

Hi, thanks, I will check that the next time I have to make some works in pro.  Doesn't see in the text what I'm doing wrong to see the polygon disappear. Doesn't undersant why is not as simple as arcmap but, learning curve I suppose.:smiling_face_with_smiling_eyes:

0 Kudos