Scheduled tasks result in 0x1 error

05-23-2022 05:36 AM
New Contributor

I built several models that edit data in a local file geodatabase. The models run fine when I execute them manually in Pro, but whenever I try to schedule them, they don't run and I end up with a 0x1 error, which appears to mean that I either don't have access to needed files or the files don't exist. I have the tasks set to run only while I'm logged in, with the highest privileges, and I still get the 0x1 error. I also made sure that my user account has full control of the folders where the scheduled script is located, as well as the geodatabases that I'm using for the tasks. Lastly, I added C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3 for the "Start in" option in the task options. I tried it with and without quotation marks to no avail. Has anyone run into this before? Any tips? 

1 Reply
MVP Frequent Contributor

does exporting the model to python script and a manual python script run succeed before trying the scheduled task option?

0 Kudos