Raster values in legend not honouring DRA

206
2
Jump to solution
07-30-2021 05:45 AM
Howeitzer
New Contributor III

I'm using a single band raster in a new layout and have activated DRA so the stretch only uses the data within the view extent. In the legend it looks like the values aren't adjusted as per the DRA. Is this a bug or is there a way to adjust the values of the raster in the legend automatically to reflect the cell values shown in the current view only?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
TomBole
Esri Regular Contributor

Hi Howeitzer, 

It is possible that you are running into a known issue - 

BUG-000112368: Raster statistics fail to update dynamically with display extent when using stretched symbology imagery and dynamic range adjustment (DRA) in ArcGIS Pro.

To confirm this please contact support. They can confirm that this is the same issue or help enter a new issue if your scenario is different. They can be contacted at https://support.esri.com/en/contact-tech-support.

Tom

View solution in original post

0 Kudos
2 Replies
TomBole
Esri Regular Contributor

Hi Howeitzer, 

It is possible that you are running into a known issue - 

BUG-000112368: Raster statistics fail to update dynamically with display extent when using stretched symbology imagery and dynamic range adjustment (DRA) in ArcGIS Pro.

To confirm this please contact support. They can confirm that this is the same issue or help enter a new issue if your scenario is different. They can be contacted at https://support.esri.com/en/contact-tech-support.

Tom

View solution in original post

0 Kudos
Howeitzer
New Contributor III

Thanks Tom I'll report the issue via the link. As a quick workaround I clipped the raster using raster functions.

0 Kudos