Quick Import from Rhino in Arc Pro

519
6
10-05-2020 11:50 PM
KrishanPareek
New Contributor III

Hey Everyone,

I am getting this error

"An error occurred while attempting to add a shape to a feature buffer. The error number from ArcObjects is: '-2147220936'. The error message from ArcObjects is: {The coordinates or measures are out of bounds.}".

 

This error comes when I am trying to quick import a 3D model from Rhino in all valid formats (.dxf,.wrl, .3ds, .dae, .obj(Y is up) etc.) to Arc GIS Pro.

 

When using a 3D analyst tool import is getting successful but the screen is just getting blank seems like I am in space i.e. out of the earth.

 

If anyone has successfully imported a 3D model from rhino to arc pro please share the steps like the coordinate system and parameters even while exporting.

Thanks in advance!!

0 Kudos
6 Replies
BruceHarold
Esri Regular Contributor

Is this using Data Interoperability? It's possible the Z values are out of range (-100000 min). Please share your data.

Sent from Outlook Mobile<https://aka.ms/blhgte> on Nokia

0 Kudos
KrishanPareek
New Contributor III

Hey Bruce,

Thanks for taking this up

I seriously think this is because of coordinates problem. But I am unable to get the desired out. Please find attached the google link of the files. I have all the file format I have tried .obj has its Y up. 

While data interoperability using .wrl format it is working fine i.e.  not getting error and geodatabase is getting created but unable to locate the model in arc pro, I have also tried switching Z to ground but no luck. Also tried using define projection but result are same.

Quick Import files - Google Drive 

Thanks in advance

0 Kudos
WilliamMorrish
Esri Contributor

Hello Krishan, 
Had a look at the data that you exported in both DAE and OBJ format. There appears to be a lot of Z-fighting going on with the surfaces plus some overpasses missing geometry in the OBJ file. 

To Geo reference the file you will need to have a real world coordinate for it to be referenced too. As the data is in local coordinates it will import to 0,0 at the equator. 

You will have to insure you use the right units too so it scales correctly. 

The two tools that will work best are "Import 3D File" which you will need a reference point for, and "Replace Multipatch" Which you will need to create a place marker multipatch in the position you wish the import object to be imported to. 

errors and empty geometry in objDAE Z-fighting issues

0 Kudos
KrishanPareek
New Contributor III

Hey William Morrish,

First of all wanna say big thank you to you for taking this up

Secondly I am not the creator of the Rhino files that were later converted to .obj and other formats. Therefore I cannot perform changes in the original files. As per your suggestions I tried importing using "3D Import files" tool providing a reference point as shown in the picture attached below but the result is same I am unable to locate my file. 

Then I tried opening the file in SketchUp and providing it the real world coordinates then finally importing back to arc pro but the result is still the same. 

What I have with me is real world coordinates, original rhino file  (units in inches) which I am converting in dae and other formats. It will be very helpful of you if you can tell me about process/steps which I am performing wrong and how to proceed forward. 

0 Kudos
KrishanPareek
New Contributor III

William Morrish

I know the problem is with georeferencing but it seems like nothing is working. I have tried to move the multipatch using modify features move tool, tried externally georeferencing it in other software no luck there as well. Am I am doing anything wrong?

0 Kudos
KrishanPareek
New Contributor III

Hey everyone,

As suggested by William Morrish you can use the “import 3D” tool that will import the 3D multipatch object but you have to be very careful with units and coordinates with the same.

In my case, I was able to import the 3D object but was unable to change the projection & coordinate values as they have already had coordinates but the wrong one.

 

I used a different way i.e. to import your 3D model to SketchUp and from SU you can convert it in DAE formats finally you can import this DAE formatted multipatch into arc pro using the "create multipatch" tool.  In this way, you won’t face the georeferencing problem.

0 Kudos