Question about selection a feature

216
4
Jump to solution
03-16-2022 08:17 AM
PROBERT68
Frequent Contributor

Hi,

I need your help on about selection issue I am having in ArcGIS Pro 2.9.1 . Whenever I use the Feature Layer ribbon and them in the map  tab. Then I hit the Select to use the rectangle and it becomes like this : 

PROBERT68_0-1647443531017.png

Then when I select a or more feature, I got this what it looks like 

PROBERT68_1-1647443600604.png

This drives me INSANE !!!

Is there a  way for me to get back to where it was normal selection as usual ?  

Thanks 

0 Kudos
1 Solution

Accepted Solutions
BryndaHatch
Esri Contributor

I found how to reproduce your issue.  It is in the Selection options, the one marked "Display the interactive selection graphic".

From the online documentation: https://pro.arcgis.com/en/pro-app/latest/help/mapping/navigation/selection-options.htm

 


  • Display the interactive selection graphic—Maintains the selection shape graphic after drawing a selection shape. This can be useful for making additional dynamic interactive selections. Click and drag the graphic to a new location and update the selection. You can also resize the graphic by clicking and dragging one of its handles.

If you uncheck that box, your select tool should go back to how you are used to.

View solution in original post

0 Kudos
4 Replies
BryndaHatch
Esri Contributor

Hello @PROBERT68 ,

I would like to try and help you but I cannot reproduce what you're saying.  The Feature Layer ribbon has no selection tools in it.  Are you just saying that you are trying to select features from a feature layer?  The Map ribbon and the Edit ribbon are the only places you can find the Select tool.  I have tried choosing the Select by Rectangle and drawing a rectangle over some points, but it just selects the points.  I cannot make it create the square of vertices you have shown in your screenshot.  Can you offer any more details to help me reproduce the issue?

Thanks.

0 Kudos
PROBERT68
Frequent Contributor

Thank you for replying... Yes I mean the Map tab. I am sorry I got messed up. I review in Pro and you are right. It was my mistake... Ooops...

I may have change something in the Options but I did look at the Selection  and Editing and test it.

 

For the Selection options:

PROBERT68_0-1647449135900.png

 

For the Editing Options:

PROBERT68_1-1647449199127.png

PROBERT68_2-1647449235574.png

I think the I may  have turn it off the "Enable and disable editing" from the Edit tab.

Now, I enabled it on and now i can see Edit tab show up on my Pro.  

Is there something you missing ?

 

Thanks for help

 

 

 

0 Kudos
BryndaHatch
Esri Contributor

I found how to reproduce your issue.  It is in the Selection options, the one marked "Display the interactive selection graphic".

From the online documentation: https://pro.arcgis.com/en/pro-app/latest/help/mapping/navigation/selection-options.htm

 


  • Display the interactive selection graphic—Maintains the selection shape graphic after drawing a selection shape. This can be useful for making additional dynamic interactive selections. Click and drag the graphic to a new location and update the selection. You can also resize the graphic by clicking and dragging one of its handles.

If you uncheck that box, your select tool should go back to how you are used to.

0 Kudos
PROBERT68
Frequent Contributor

That helps ! Thank you !

0 Kudos