Projecting to the same spatial reference, making error?

02-17-2021 06:51 PM
Labels (2)
Esri Contributor

To all fellow geographers!

I have an issue with projecting my feature class when using project tool. I got a CAD datasets and tried to make a modelbuilder to make all the layers having the same spatial reference.

Before making the model builder, I used one feature class if the overall process will be working smoothly. Below is the process.

Choose one layer from CAD dataset -> Export Data to Feature Class in gdb -> Define projection of that feature class with EPSG 5186 -> Project the feature class to EPSG 5186 again

Projecting the feature class to the same spatial reference will be necessary if I want to run the model builder for a number of feature classes. For example, 50 feature classes having 5186 and 5187 coordinate systems. I want to make them all have the same 5186 reference after the model builder. 

At the last step of the process, I got an error "Error 00210" which is related with data locking, incorrect path, and limited access rights. The thing I am so confused with this error and don't know where to start fix is that I solved all those three issues.


I swear there's only this aspx using the data (no data locking), path works fine after tested with exporting another data to the same path, and work with the admin account.

Did it occur since I project the feature class into the same spatial reference? But, when I tried projecting another sample feature class to the same spatial reference it worked very fine. 

If anyone know how to fix, or at least why this error happened, please don't hesitate to make a note :)

Thank you very much!

0 Kudos
2 Replies
MVP Esteemed Contributor

output names must differ from inputs

check your environment settings to ensure that you allow for overwriting of existing datasets, otherwise if an output already exists (that is, you try to use the same name), it will fail

... sort of retired...
0 Kudos
Esri Contributor

Hi hm_stella,


Did you tried to change the output location when you project this data? 

The error could be related to this specific feature layer, it might be that one or more of the columns are not valid (reserved word or too many characters). 


It would be a good idea If you could show me your model and the data that you're trying to process.



Rawan Saleh