Problems Updating Model Metadata in ArcGIS Pro 2.1.3

1144
1
Jump to solution
06-22-2018 02:28 PM
BlytheSpendlove1
New Contributor III

I wrote metadata for a couple models that I created in ArcGIS Pro, and upon finding something in the metadata I wanted to change, I went back again to edit the metadata (right clicked on model in Catalog pane > Edit Metadata). However, after making my changes and clicking "Save," my work did not save. I have tried opening and closing the metadata editor, restarting Pro, restarting my computer...nothing.

Does anyone know why this is happening or how (any way, custom python scripts, whatever) I can most easily work around this bug and update my metadata? This is the latest in a long line of difficulties I have been having in saving metadata for models and script tools in ArcGIS Pro.

Miscellaneous but Possibly Pertinent Information:

- Earlier today I was able to create the metadata that I am trying to update. However, now I cannot even create or edit metadata for a different model within the toolbox that I am working with.

-Even earlier today, I updated my ArcGIS Pro version from 2.1.2 to 2.1.3 

- My models are saved in a custom toolbox that I created. Originally I created the toolbox in ArcGIS Pro, but I have been cycling through different versions of my final toolbox so I copied the toolbox (several times now) in ArcCatalog and then continued to edit the new copy in ArcGIS Pro. The tools run fine. I just have trouble creating metadata that persists.

- The other week, when I was using ArcGIS Pro version 2.1.2, I discovered that changing the name of a parameter in a model deletes the metadata for that parameter (taught me to save all my model metadata in an external file), but I have not made any changes to the model that I am trying to update today.

Thanks!

Blythe

0 Kudos
1 Solution

Accepted Solutions
BlytheSpendlove1
New Contributor III

Update! This morning it worked!

I have no idea what I did different, but here's a list of suggestions I've compiled for anyone else having trouble with metadata in models for ArcGIS Pro!

  • Click Save after every box/section completed in the metadata
  • Regularly save your project too
  • If the program stops saving your metadata....try restarting Pro, restarting your computer, restarting Pro again, closing things and restarting a couple more times, etc. It might work the next day! 
  • If you are creating models to be run in the geoprocessing pane and want to create dialog explanations for each parameter input like I did, finalize all your model parameter names BEFORE creating the dialog explanations for the model steps (Side note: to create dialog explanations, Edit Metadata  and then in the Item Description section, scroll down to Syntax, click the parameter name, and enter your text in "Dialog Explanation")
  • Keep a separate external text file with all of your metadata dialog explanations etc., just in case something odd happens and you loose all your data, or in case you have to go back and change parameter names.
  • When documenting the dialog explanations for your models,  it's probably not a good idea to switch between tasks (opening and editing models, editing metadata) at the same time. Sit down and figure out what you want to write for each section in the metadata first. Take that time to open and close all your models to remember what you did, edit typos etc. THEN when you are ready to focus solely on the metadata, start filling out the metadata
  • Check regularly to make sure that when you hit Save and the syntax box closed, that it actually DID save your edits.

Cheers!

Blythe

View solution in original post

1 Reply
BlytheSpendlove1
New Contributor III

Update! This morning it worked!

I have no idea what I did different, but here's a list of suggestions I've compiled for anyone else having trouble with metadata in models for ArcGIS Pro!

  • Click Save after every box/section completed in the metadata
  • Regularly save your project too
  • If the program stops saving your metadata....try restarting Pro, restarting your computer, restarting Pro again, closing things and restarting a couple more times, etc. It might work the next day! 
  • If you are creating models to be run in the geoprocessing pane and want to create dialog explanations for each parameter input like I did, finalize all your model parameter names BEFORE creating the dialog explanations for the model steps (Side note: to create dialog explanations, Edit Metadata  and then in the Item Description section, scroll down to Syntax, click the parameter name, and enter your text in "Dialog Explanation")
  • Keep a separate external text file with all of your metadata dialog explanations etc., just in case something odd happens and you loose all your data, or in case you have to go back and change parameter names.
  • When documenting the dialog explanations for your models,  it's probably not a good idea to switch between tasks (opening and editing models, editing metadata) at the same time. Sit down and figure out what you want to write for each section in the metadata first. Take that time to open and close all your models to remember what you did, edit typos etc. THEN when you are ready to focus solely on the metadata, start filling out the metadata
  • Check regularly to make sure that when you hit Save and the syntax box closed, that it actually DID save your edits.

Cheers!

Blythe