Problem connecting to a WCS server with ArcGIS Pro

735
5
01-24-2020 09:16 AM
Simonde_Bonviller
New Contributor

Hello everyone!
I am currently trying to connect to a WCS server (specifically, the US 3DEP elevation data; link:https://elevation.nationalmap.gov/arcgis/services/3DEPElevation/ImageServer/WCSServer?request=GetCap...). Although the server now appears in my catalog, I cannot add any data to my map in ArcGIS Pro. 
I have to tell that Im new with ArcGIS Pro (although I have been working with other GIS softwares for some time now).
Am I doing something wrong, or does this ring a bell to someone?

Cheers,

Simon

Tags (1)
5 Replies
KevinHanson1
New Contributor II

Hi Simon, 

I have also noticed that problem with a different WCS service where it works fine in ArcMap 10.7 but won't load in ArcGIS Pro 2.5. Similarly, I was able to connect to the 3DEP WCS source in ArcGIS Pro 2.5 in the Catalog Pane but am not given any option to load the data into a map. Maybe Esri will reach out.

-Kevin 

0 Kudos
SheaBurns1
New Contributor

Anyone have any luck or an update on using the 3DEP WCS source? I can add it as a WCS Server in ArcMap and ArcGIS Pro, but, like Kevin, neither application shows any products listed that can be added to the map. Using the Add Data button in ArcGIS Pro gives the message "This container is empty." when  inside the 3DEPElevation container listed on the server.

Shea

0 Kudos
TrevorHobbs
New Contributor II

I too am having the same issue in ArcGIS Pro 2.6.0, using the 3DEP WCS elevation server endpoint...

https://elevation.nationalmap.gov/arcgis/services/3DEPElevation/ImageServer/WCSServer?request=GetCap...). 

The same server endpoint works fine in ArcGIS Desktop.  In ArcGIS Pro, I can successfully create a new connection file (.wcs) for it and add the connection to the project.  But, from the catalog pane, it is not possible to drag the service into a map, or right click and add it to a map.

I've tried these two things, with no positive outcome:

  • Removing various trailing portions of the URL past the final forward slash.
  • Changing the version type in the Add WCS Server Connection dialogue.

This web coverage service is a really important data resource for those who need access to seamless elevation data (pixel values, not the cached pics) for analyses and modeling, which would otherwise be cumbersome or cost prohibitive to download and work with individual stand alone rasters.

Hopefully someone at ESRI can look into this.

Thank you!  

0 Kudos
TrevorHobbs
New Contributor II

This doesn't solve the WCS issue, but you can add the 3DEP image service endpoint to ArcGIS Pro, then set the processing template to "none".  This provides access to the underlying pixel values, and performs essentially the same as a WCS.  

 

  • In the Catalog pane, add a new ArcGIS Image Server
  • Add the 3DEP url (link in previous message above)
  • Expand the image service connection file and add the 3DEP image service to the map
  • Right click the layer (which comes in as a hillshade by default), go to the Processing Templates tab
  • Set the processing template to "None" (last choice in the list).

This provides access to the elevation values.

Hopefully this provides the same functionality as one would expect from a WCS.

0 Kudos
isburns
New Contributor III

I tried this again by following the steps as directed in https://www.usgs.gov/media/videos/lesson-10f-national-map-3dep-elevation-web-service-arcmap and managed to add the service to a map successfully. As @TrevorHobbs noted, it was not added as a WCS Server, which I think was my problem before. For me, the connection to add via Catalog was "New ArcGIS Server Connection" in ArcGIS Pro and "Add ArcGIS Server" in ArcMap. I'm not sure if it matters, but the URL I added was https://elevation.nationalmap.gov/arcgis/services/3DEPElevation/ImageServer/WCSServer without the query string.

Shea

 

0 Kudos