Pro 2.9 crashes when publishing service

161
2
Jump to solution
01-13-2022 08:34 PM
PeterMilenkovic
Occasional Contributor

Hi All,

Installed Pro2.9 and now it crashes whenever i try overwrite a map service, i have run a repair on the installation, uninstalled/reinstalled. Anyone else experience this?

Reverted to 2.8 with no issues.

0 Kudos
1 Solution

Accepted Solutions
PeterMilenkovic
Occasional Contributor

After a bit of testing with my colleague we have noted this behavior only occurs if we run pro as administrator (which we have to as the aprx is saved on a sever with restrictive access). If we run pro as a different user (and use our 'admin account')  overwriting services are successful.

View solution in original post

2 Replies
BrianWilson7
Regular Contributor

I installed 2.9 shortly after it was released, I always test versions before deploying to the people who need to rely on it. I struggled with various flaky server issues like publishing, first figured that I was doing something wrong, Then finally found out I could not test branch versioning with 10.8 on the server because it's simply not compatible with Enterprise less than 10.9. I dropped back to Pro 2.8 and things have been working better for me. 

I wish they would just say in the system requirements that it wants to have a 10.9 server. Maybe it's supposed to work with everything BUT branch versioning? But that was my experience. I am not going to go back up to 2.9 until I have deployed 10.9 on my server.

My team statewide has settled on 2.8 and that's not compatible with 10.9. I can't have two servers because $$$. It's awkward.

 

0 Kudos
PeterMilenkovic
Occasional Contributor

After a bit of testing with my colleague we have noted this behavior only occurs if we run pro as administrator (which we have to as the aprx is saved on a sever with restrictive access). If we run pro as a different user (and use our 'admin account')  overwriting services are successful.