Select to view content in your preferred language

Pairwise Dissolve GP tool creating gaps in output lines

957
4
Jump to solution
03-03-2022 06:15 AM
Labels (2)
LindsayRaabe_FPCWA
Regular Contributor II

I have a model that does a number of steps to a state wide road network. I've confirmed that all the way through the model, the generated data maintains integrity, but after running a final Pairwise Dissolve, gaps of roughly 0.7-0.9 metres wide are appearing randomly (not many) between the start/ends of some line features (image below). Any idea how I can prevent this?

LindsayRaabe_FPCWA_0-1646316813319.png

 

Lindsay Raabe
GIS Officer
Forest Products Commission WA
0 Kudos
1 Solution

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

Maintain curve segments environment setting is it set to preserve them?

Is Create multipart features set or unset?

and finally, can you confirm that the features actually met at their endpoints?

The dissolve won't make segments meet if they ever met in the first place, that would require

Extend Line (Editing)—ArcGIS Pro | Documentation


... sort of retired...

View solution in original post

0 Kudos
4 Replies
DanPatterson
MVP Esteemed Contributor

Maintain curve segments environment setting is it set to preserve them?

Is Create multipart features set or unset?

and finally, can you confirm that the features actually met at their endpoints?

The dissolve won't make segments meet if they ever met in the first place, that would require

Extend Line (Editing)—ArcGIS Pro | Documentation


... sort of retired...
0 Kudos
LindsayRaabe_FPCWA
Regular Contributor II

Maintain curve segments is not enabled. 

No multiparts

Yes they met originally. 

Lindsay Raabe
GIS Officer
Forest Products Commission WA
0 Kudos
DanPatterson
MVP Esteemed Contributor

Your data to Tech Support for testing would be best.  If it can be replicated it would be a nasty bug for anyone needing to do network stuff.


... sort of retired...
0 Kudos
LindsayRaabe_FPCWA
Regular Contributor II

I think the Maintain Curve Segments setting has resolved the issue. The 2 breaks I've found previously are now connected. Will keep an eye out for others, but hopefully thats it! Thanks Dan. 

LindsayRaabe_FPCWA_0-1646359626551.png

 

Lindsay Raabe
GIS Officer
Forest Products Commission WA