Select to view content in your preferred language

Misalignment between AutoCAD Map 3D 2022 and ArcGIS PRO

06-20-2022 11:02 AM
New Contributor


I got few issues with the misalignment between AutoCAD Map 3D and ArcGIS PRO.

The coordinate system in AutoCAD is UTM83-10, see attached file.

The coordinate system in ArcGIS PRO is the same, see attached file as well.

I searched some post in this community that saying might be the transformation's problem, and I attached my transformation setup.

Please help for how to setup properly.

Your help is my really appreciated.




0 Kudos
8 Replies
Frequent Contributor III

Detail what you mean by misalignment

Off by inches/cm off by miles/kilometers etc....

Do you know for certain that the map in AutuCAD map is even drawing in the correct location?

Can you import a reference section layer into the .dwg to verify it is correctly located. 

What process did you use to import the map

0 Kudos
New Contributor

I am using Autodesk connector for ArcGIS to bring GIS info into AutoCAD Map 3D.

I inserted AutoCAD drawings into Map 3D, and loaded GIS info to create my CAD drawings for easy and fast plot out to share.


0 Kudos
New Contributor

Below is F2 in Map 3D showed the misalignment:


Distance = 1.285, Angle in XY Plane = 32.7895, Angle from XY Plane = 0.0000
Delta X = 1.081, Delta Y = 0.696, Delta Z = 0.000

The offset is in meter.

0 Kudos
Frequent Contributor

One thing People seem to forgot is when you add the data to ArcGIS Pro, the basemap is already set to default to WGS1984 Web Mercator (auxiliary sphere). So, if you have not already change to your projection to set UTM83-10. Also, check each ESPG to match both..

Can you screenshot both your data and ArcGIS Pro to us ?

Here is an example from ESRI Australia .

0 Kudos
New Contributor

See attached.

0 Kudos
MVP Notable Contributor

If they are in the same coordinate system, a transformation shouldn't be required.

Have you tried removing the transformation and see how it lines up?


0 Kudos
New Contributor

For anyone experiencing this problem, here is the solution we found to the problem.

Data were being added as feature services to Map3D using the ArcGIS Connector from an on-prem ArcGIS Portal. The issue described was found to only occur on layers that had z-values enabled. Data in geodatabase/feature service were UTM83-10, feature service was UTM83-10. Drawing was set to UTM83-10.

The problem was that the ArcGIS connector defaults to LL84, no matter what CRS/projection is set in the drawing or feature service.

The solution is to run the MAPARCGISCONNECTOROPTION command, and select '2', the option to use the coordinate system that the drawing is set to.

I'm not sure why the ArcGIS Connector would default to a projection that is different than both the drawing AND the published feature service, but it is.


0 Kudos
Occasional Contributor III

Did you have to do anything else to make it work?  I have similar problem, image I georeferenced into FL83-EF using ArcPro.  Updated it and Arc can locate it properly now, but when I try to IINSERT it into Map3D it comes in the wrong location.  Map3D coordinate system is set properly, units set properly, image world file is correct, no apparent reason why it shouldn't come into Map3D fine, but it doesn't.  Is there some other obscure Map3D option somewhere that affects this?


EDIT: I was able to make a georeferenced raster Map3D could properly read by changing my georeferencing workflow in Pro.  Previously I was taking a raster with no georeferencing at all, using Pro to georeference it in, and clicking 'Save', which would write a world file, but for some reason it doesn't pick up the coordinate system, GIS programs would still say 'Unknown'.  So after saving it I'd use the assign the right coordinate system to the raster, which produced a raster Map3D couldn't locate but Arc could.  But if when I finished georeferencing in Arc and chose Save As New it produced a raster Map3D could locate.  No idea what exactly got done differently, but Save As New from ArcGIS solved the problem.

0 Kudos