Make hyperlinks in a popup appear in a default browser

1770
12
Jump to solution
03-18-2021 02:57 PM
Labels (1)
MichaelMorgan4
New Contributor III

In ArcGIS Pro 2.7.2 (latest patch as of 3/15/2021), links from a popup now go to a mini browser within Arc Pro. In prior versions of Arc Pro, links go to our default browser, which for me is Firefox. This would in turn show the link in my PDF viewer (Bluebeam), because my links are typically for PDF documents. This worked great, and I would like to show my links in Firefox again, but doing this is not obvious in Arc Pro. How do I revert link behavior to go to a standard browser instead of the whittled down Arc Pro browser?

1 Solution

Accepted Solutions
JaredNuss
New Contributor

I have put in an issue for this same thing. A work around is adding an 'image' element to the pop-up configuration, even if the image element is left blank. If you blank out all the fields of the element and put it at the bottom of the list you won't notice it, and the links will open in their correct program.

View solution in original post

12 Replies
CraigRussell
Esri Contributor

I've tested this on a couple of 2.7.2 installs and this appears to be a bug/regression, suggest raising it with support.

I was going to check the release notes to see if there was anything relevant added/changed around this but I can't access https://pro.arcgis.com at the moment, so that's another problem...

0 Kudos
JaredNuss
New Contributor

I have put in an issue for this same thing. A work around is adding an 'image' element to the pop-up configuration, even if the image element is left blank. If you blank out all the fields of the element and put it at the bottom of the list you won't notice it, and the links will open in their correct program.

View solution in original post

NickHarvey
Occasional Contributor II

Thanks Jared - I haven't been able to duplicate this workaround at 2.7.3.  In the end we want our field-based hyperlinks (pipe video) to work from the attribute table too, but will use custom popups if need be.  Bottom of this thread had this as an enhancement I think:  ENH-000107706. 

0 Kudos
NickHarvey
Occasional Contributor II

This appears to be fixed at 2.8.0 (launches default browser when clicking hyperlinked documents).  However, hyperlinks containing single quotes are not working as expected.  Have put in a Support case.

-Nick

0 Kudos
NickHarvey
Occasional Contributor II

Looks like hyperlinks containing single quotes are working ok at 2.8.2 -  released today. 

0 Kudos
GaryB
by
New Contributor II

I can't seem to get that work around to work.  Here's the URL that I have built up but it still goes to ArcGIS Pro's little browser which is not what I want.

<a href="https://ngmdb.usgs.gov/topoview/viewer/#14/34.123/-87.456"><img width="20" height="20" border="0" align="center" src=""/>Topoview</a>

 

0 Kudos
NickHarvey
Occasional Contributor II

@GaryB  -Hey Gary - Here's what a field-based version looks like in my installation of Pro 2.8.1 (below) - Which version are you using?

NickHarvey_0-1628004383192.png

NickHarvey_1-1628004422660.png

-Nick 

0 Kudos
GaryB
by
New Contributor II

Thanks Nick, unfortunately I'm stuck with 2.7.3 for the moment. 

0 Kudos
MikeRatcliffe
Occasional Contributor

Yes, this must be fixed.  As we support both ArcGIS Desktop and ArcGIS Pro environments, a fully functional .PDF becomes essential, NOT defaulting to a limited .pdf browser.

0 Kudos