Layer To KML

942
10
01-02-2021 08:29 AM
Labels (2)
Andreas
New Contributor III

Hi,

I try to export a vector layer to KML with Pro 2.7, so that I can see my configured Pop-ups in Google Earth. But this doesn't work. After running the tool "Layer To KML" Google Earth still shows my (visible) attributes but not the confgured pop-up. Further more, a popup for the layer does show the label I entered under contents (and in the layer properties) what is ok, but it also shows the name of the datasource (a shapefile) - I don't want that. I tried Map To KML with the same result. At last, one of my fields has the alias "KMLSnippet" which I hoped to see in Google Earth, but it has also no effect.

Is there something I am missing?

10 Replies
RolandDuhaime
New Contributor III

Google Earth can open shapefiles. You might have better luck with that approach.  There is a limit to the number of polygons though.  You can then save the layer from Google Earth as a KML file.

0 Kudos
Andreas
New Contributor III

Thank you Roland, but thats not my problem. I have footprints of buildings from OSM, a few thousand. Although GE rendering gets slow with a certain amount.

0 Kudos
DanPatterson
MVP Esteemed Contributor

did you customize the popups?

apparently there are a number of steps that need to be taken to get  to the "what you see is what you get" stage

KML conversion—ArcGIS Pro | Documentation


... sort of retired...
Andreas
New Contributor III

Hello Dan, thank you for your respond! Yes, I think, I did ;). I changed the entries in the "Configure Pop-ups" for the Layer and in Pro I get what I intended to show. But it is not exported into the kmx-File, it's still the "standard" attribute list.

ThomasL
Occasional Contributor

I know the "Layer To KML" tool was updated in Pro 2.7 and that has unfortunately resulted in other issues like the “FolderPath” feature being bugged:

https://community.esri.com/t5/arcgis-pro-questions/field-name-folderpath-in-pro-2-7-stops-export-of-...

 

0 Kudos
Andreas
New Contributor III

Hi Thomas, thank you for your hint. My problem occured with 2.6.3 and I upgraded to 2.7. I hoped that possible bug could be fixed, also because they worked on the KML part and added the Map To KML tool. Unfortunately, this wasn't the case.

0 Kudos
CarlMorrison
Occasional Contributor
This may not help entirely, but I found that re-ordering my fields and hiding fields that I did not want in GE made a difference as to how the table of contents and pop-ups presented in GE.
HeatherAlexander
New Contributor II

I'm running 2.9, I'm getting the same issues, I tried the same fixes you did but I still get the default pop ups, even disabling the popups doesnt do anything.  I tried to go back to arcmap to customize the popups to see if i could do it that way but I forget how to do it in arcmap.  just wondering if anyone has any new ideas on this

 

CPaulman
New Contributor II

I was running into the same problem where my KML file was giving the value of "no name" for each of my layer's records in the Google Earth Table of Contents.

I tried 1) Properties > Display > Display Field and 2) Configure Popups with no luck. 

I then tried setting my Labeling Properties and turning on my labels. THIS WORKED! Yahoo. I now have the field that I included in my labeling properties showing up in the TOC in GE.