Iterating through multiple spatial join

178
0
03-17-2021 11:16 AM
Labels (1)
WillvanHeerden
New Contributor II

Good day

Working within a model (see attached image below), I am attempting to iterate through a feature dataset containing a collection of point and polygon feature classes. I've ensured the outputs all have their own %Name% and validated the model before executing. However, the result I get is not expected. I am running 3 spatial join processes and getting an expected return from the first spatial join but the second and the third spatial join processes produce outputs containing a join between the feature class input and the first feature class in the feature dataset.

Note the following:

- the results for the first feature class in the iteration is correct for all three spatial join processes

- I have already tried changing the name initial iterated feature class to %Name%

- the problem persists even if I specify what type (point polygon etc.) the iteration should read

- when I run the process for each feature class individually outside of an iteration the result is correct

- I researched the topic and found similar cases

Does anyone have a workaround for this error/bug or am I erring along the way?

Kind Regards

Will van Heerden

WillvanHeerden_0-1616003694409.png

 

0 Kudos
0 Replies