Issues creating large area Vector TPK

06-02-2022 09:41 AM
New Contributor III

I'm trying to create a custom vector tile package for a large area (The Eastern area states in yellow on the map below with a 50 mile buffer) and but the NHD Waterbodies dataset seems to be causing issues.  I was able to successfully create the vector tile package for all the other areas on the map without this issue from the same data source.

NWCG Geographic AreasNWCG Geographic Areas

I realize its a large area of several million sq miles (my .gdb is 39GB of data), but I have successfully created VTPK's for all the other areas in the map above.  Generally the Create Vector Tile Package tool has only taken 8-16 hours to complete the VTPK, but for the Eastern Area I've let the tool run for 8 days and the tool only reports being 25% done and then the work computer I'm running this on ends up doing an automatic reboot over night.

For troubleshooting, since the issue appeared to be coming from the NHD Waterbodies layer in the map, I turned those layers off and the Eastern area VTPK was created in 7 hours.  I've tried running repair geometry with both validation methods with no success.  As the data I was using is a copy that my Agency (USFS) was providing, I went and downloaded the NHD State databases for my area of interest, merged all the NHDWaterbody feature classes and deleted identical records but that has not helped either.

I'm now at a loss as to what I can do to fix this.  I do realize this is a large area, but both the Southern and Alaska areas are of similar size and feature counts in NHDWaterbody is not dramatically different.  I do have 3 copies of the NHD Waterbodies in the map and am filtering them by size with different visibility ranges so all waterbodies are only showing up when zoomed in beyond 1:72,224 which is the same settings used  successfully on the other areas.  I've also tried using both the NVME drive and the standard hard drive with no noticeable change.

Here is a screen capture of the tools progress about 2.5 hours after starting.  It always stalls on that layer.  

vtpk screen capture.PNG

In case it helps, here are my parameters, with the same settings used for all the other areas with no issues.

create VTPK parameters.PNG

ArcGIS Pro Version: 2.9.2 with a named user license (Advanced) that is not checked out for offline use.

I'm out of ideas and could use some help with what the issue is and how this might be fixed?

0 Kudos
0 Replies